summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2015-03-15 23:12:32 +0100
committerRicardo Wurmus <rekado@elephly.net>2015-03-20 22:54:10 +0100
commit3e3d47fc5347a5032fd2039831be1dc1d80576ed (patch)
tree603c4c6742565a5c80e98418a2ec60f0429d2ac7
parent0f49d7ba70ed91b3c9427130180924be6aeb475f (diff)
downloadguix-patches-3e3d47fc5347a5032fd2039831be1dc1d80576ed.tar
guix-patches-3e3d47fc5347a5032fd2039831be1dc1d80576ed.tar.gz
gnu: gtk+-2: build gobject introspection typelib file.
* gnu/packages/gtk.scm (gtk+-2): add `gobject-introspection' to the native-inputs to install typelib file.
-rw-r--r--gnu/packages/gtk.scm4
1 files changed, 3 insertions, 1 deletions
diff --git a/gnu/packages/gtk.scm b/gnu/packages/gtk.scm
index fef5a814db..b3688d5ec1 100644
--- a/gnu/packages/gtk.scm
+++ b/gnu/packages/gtk.scm
@@ -408,10 +408,12 @@ is part of the GNOME accessibility project.")
(native-inputs
`(("perl" ,perl)
("glib" ,glib "bin")
+ ("gobject-introspection" ,gobject-introspection)
("pkg-config" ,pkg-config)
("python-wrapper" ,python-wrapper)))
(arguments
- `(#:phases
+ `(#:make-flags '("CC=gcc")
+ #:phases
(alist-cons-before
'configure 'disable-tests
(lambda _