summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLeo Prikler <leo.prikler@student.tugraz.at>2021-06-03 08:49:18 +0200
committerLeo Prikler <leo.prikler@student.tugraz.at>2021-06-03 08:49:18 +0200
commitf6a979860c4550e35b595d3ecdfc5be490c40836 (patch)
tree85637ba9dfb7bd06b491ba8c45ea13ef3ca314ae
parenta923127d3051841e4187ee5e817f6c85e6387c3e (diff)
downloadguix-patches-f6a979860c4550e35b595d3ecdfc5be490c40836.tar
guix-patches-f6a979860c4550e35b595d3ecdfc5be490c40836.tar.gz
gnu: openshot: Use free font.
* gnu/packages/video.scm (openshot)[inputs]: Use font-dejavu. [patch-font-location]: Adjust accordingly.
-rw-r--r--gnu/packages/video.scm7
1 files changed, 4 insertions, 3 deletions
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index 2e9f9e3267..d85a4045f1 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -4535,7 +4535,7 @@ API. It includes bindings for Python, Ruby, and other languages.")
(build-system python-build-system)
(inputs
`(("ffmpeg" ,ffmpeg)
- ("font-ubuntu" ,font-ubuntu)
+ ("font-dejavu" ,font-dejavu)
("libopenshot" ,libopenshot)
("python" ,python)
("python-pyqt" ,python-pyqt)
@@ -4556,10 +4556,11 @@ API. It includes bindings for Python, Ruby, and other languages.")
(invoke "python" "src/tests/query_tests.py")))
(add-after 'unpack 'patch-font-location
(lambda* (#:key inputs #:allow-other-keys)
- (let ((font (assoc-ref inputs "font-ubuntu")))
+ (let ((font (assoc-ref inputs "font-dejavu")))
(substitute* "src/classes/app.py"
(("info.IMAGES_PATH") (string-append "\"" font "\""))
- (("fonts") "share/fonts/truetype")))
+ (("fonts") "share/fonts/truetype")
+ (("[A-Za-z_-]+.ttf") "DejaVuSans.ttf")))
#t))
(add-before 'install 'set-tmp-home
(lambda _