summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2021-12-22 05:42:23 +0100
committerRicardo Wurmus <rekado@elephly.net>2021-12-22 05:43:02 +0100
commitdce3415a74e04e97d10212e799b9b2e63a32a286 (patch)
tree086eda9736a2b522d53a553135c9cd39ae312976
parentc0c878856edba12d148aa3ec3dfbe7381db1f9f9 (diff)
downloadguix-patches-dce3415a74e04e97d10212e799b9b2e63a32a286.tar
guix-patches-dce3415a74e04e97d10212e799b9b2e63a32a286.tar.gz
gnu: strace: Update to 5.15.
* gnu/packages/linux.scm (strace): Update to 5.15. [arguments]: Remove trailing #T from build phases; disable one more test.
-rw-r--r--gnu/packages/linux.scm14
1 files changed, 7 insertions, 7 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 7e6f0c7010..27ec9fa82e 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -12,7 +12,7 @@
;;; Copyright © 2016 Raymond Nicholson <rain1@openmailbox.org>
;;; Copyright © 2016 Mathieu Lirzin <mthl@gnu.org>
;;; Copyright © 2016, 2018, 2019, 2020, 2021 Nicolas Goaziou <mail@nicolasgoaziou.fr>
-;;; Copyright © 2016, 2018, 2019, 2020 Ricardo Wurmus <rekado@elephly.net>
+;;; Copyright © 2016, 2018, 2019, 2020, 2021 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2016 David Craven <david@craven.ch>
;;; Copyright © 2016 John Darrington <jmd@gnu.org>
;;; Copyright © 2016, 2017, 2018, 2019, 2020, 2021 Marius Bakke <marius@gnu.org>
@@ -2340,7 +2340,7 @@ Zerofree requires the file system to be unmounted or mounted read-only.")
(define-public strace
(package
(name "strace")
- (version "5.13")
+ (version "5.15")
(home-page "https://strace.io")
(source (origin
(method url-fetch)
@@ -2348,7 +2348,7 @@ Zerofree requires the file system to be unmounted or mounted read-only.")
"/strace-" version ".tar.xz"))
(sha256
(base32
- "0mmns22bjjvakxj29si0x4dcylcgy26llpcimkb0llcxif439k2s"))
+ "1p3jipp6mj5fwfcjdnp6xhxk84z07jy5qhjlqr6jjdbk54pw5jpb"))
(patches (search-patches "strace-readlink-tests.patch"))))
(build-system gnu-build-system)
(arguments
@@ -2357,8 +2357,7 @@ Zerofree requires the file system to be unmounted or mounted read-only.")
(add-after 'unpack 'patch-/bin/sh
(lambda _
(substitute* "src/strace.c"
- (("/bin/sh") (which "sh")))
- #t))
+ (("/bin/sh") (which "sh")))))
(add-after 'unpack 'disable-failing-tests
(lambda _
(substitute* "tests/Makefile.in"
@@ -2366,8 +2365,9 @@ Zerofree requires the file system to be unmounted or mounted read-only.")
;; extended.
(("^\tstrace-DD?D?\\.test \\\\.*") "")
(("^\tpidns-cache.test \\\\.*") "")
- (("^\t.*--pidns-translation.test \\\\.*") ""))
- #t)))
+ (("^\t.*--pidns-translation.test \\\\.*") "")
+ ;; This one fails with an encoding error.
+ (("^\t.*net-yy-unix.test \\\\.*") "")))))
;; Don't fail if the architecture doesn't support different
;; personalities.
#:configure-flags '("--enable-mpers=check")