summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Enge <andreas@enge.fr>2013-10-01 20:25:30 +0200
committerAndreas Enge <andreas@enge.fr>2013-10-01 20:25:30 +0200
commit1c8362a89e05d0602a7220e5dc06ca8c7aad281c (patch)
treea82dc730ab69e9899d111194859c61f33d57711b
parent8b79a5472deb0bb88adfa87d5144721b4b671a96 (diff)
downloadguix-patches-1c8362a89e05d0602a7220e5dc06ca8c7aad281c.tar
guix-patches-1c8362a89e05d0602a7220e5dc06ca8c7aad281c.tar.gz
gnu: gtk+-2: Update to 2.24.21.
* gnu/packages/gtk.scm (gtk+-2): Update to 2.24.21, add inputs perl and python.
-rw-r--r--gnu/packages/gtk.scm11
1 files changed, 7 insertions, 4 deletions
diff --git a/gnu/packages/gtk.scm b/gnu/packages/gtk.scm
index cef9d73b26..6854837318 100644
--- a/gnu/packages/gtk.scm
+++ b/gnu/packages/gtk.scm
@@ -246,21 +246,24 @@ is part of the GNOME accessibility project.")
(define-public gtk+-2
(package
(name "gtk+")
- (version "2.24.20")
+ (version "2.24.21")
(source (origin
(method url-fetch)
- (uri (string-append "mirror://gnome/sources/gtk+/2.24/gtk+-"
+ (uri (string-append "mirror://gnome/sources/" name "/"
+ (string-take version 4) "/" name "-"
version ".tar.xz"))
(sha256
(base32
- "18qdvb7nxi25hfnpmcy01p3majw9jnx83ikm263dk9rrjazvqrnc"))))
+ "1qyw73pr9ryqhir2h1kbx3vm70km4dg2fxrgkrdlpv0rvlb94bih"))))
(build-system gnu-build-system)
(propagated-inputs
`(("atk" ,atk)
("gdk-pixbuf" ,gdk-pixbuf)
("pango" ,pango)))
(inputs
- `(("pkg-config" ,pkg-config)))
+ `(("perl" ,perl)
+ ("pkg-config" ,pkg-config)
+ ("python-wrapper" ,python-wrapper)))
(arguments
`(#:phases
(alist-replace