summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2022-01-27 13:11:14 -0500
committerLeo Famulari <leo@famulari.name>2022-01-28 14:03:03 -0500
commite3abc53c7e8bcb93b3309aa223a3d68f8cded5f3 (patch)
tree790ee45bdb345985cb2ce91ceced42b365865eb6
parent54add2e1ba1a5729fbf5b34854a961edfdd17334 (diff)
downloadguix-patches-e3abc53c7e8bcb93b3309aa223a3d68f8cded5f3.tar
guix-patches-e3abc53c7e8bcb93b3309aa223a3d68f8cded5f3.tar.gz
gnu: python-pyqtwebengine: Remove a transitive dependency on QtWebKit.
Since QtWebKit and QtWebEngine are alternative web rendering engines, it doesn't make sense for one to depend on the other. See <https://issues.guix.gnu.org/53289> for more information about this change. * gnu/packages/qt.scm (python-pyqtwebengine)[inputs]: Replace python-pyqt with python-pyqt-without-qtwebkit.
-rw-r--r--gnu/packages/qt.scm6
1 files changed, 4 insertions, 2 deletions
diff --git a/gnu/packages/qt.scm b/gnu/packages/qt.scm
index 49d514503d..ca97725052 100644
--- a/gnu/packages/qt.scm
+++ b/gnu/packages/qt.scm
@@ -2173,7 +2173,7 @@ contain over 620 classes.")
(inputs
`(("python" ,python-wrapper)
("python-sip" ,python-sip)
- ("python-pyqt" ,python-pyqt)
+ ("python-pyqt" ,python-pyqt-without-qtwebkit)
("qtbase" ,qtbase-5)
("qtsvg" ,qtsvg)
("qtdeclarative" ,qtdeclarative)
@@ -2232,7 +2232,9 @@ set of three modules. Prior to v5.12 these bindings were part of PyQt
itself.")
(license license:gpl3)))
-;; XXX: This is useful because qtwebkit does not build reliably at this time.
+;; XXX: This is useful for removing qtwebkit from other packages' dependency
+;; graphs, as well as for preventing python-pyqtwebengine from transitively
+;; depending on qtwebkit.
;; Ultimately, it would be nicer to have a more modular set of python-pyqt-*
;; packages that could be used together.
(define-public python-pyqt-without-qtwebkit