summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2022-01-28 16:48:04 +0100
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2022-01-28 16:48:04 +0100
commitd961498fcda021c7e36a8ab6299ead0629f9c194 (patch)
treebcf870b2befb777c4aa59114de93a13734d6ccba
parent5c1a1cecaa17f4c1e16d13891f36b4ec0b998cec (diff)
downloadguix-patches-d961498fcda021c7e36a8ab6299ead0629f9c194.tar
guix-patches-d961498fcda021c7e36a8ab6299ead0629f9c194.tar.gz
gnu: Add texlive-tabu.base-for-series-11168
* gnu/packages/tex.scm (texlive-tabu): New variable.
-rw-r--r--gnu/packages/tex.scm44
1 files changed, 44 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index d263be630d..9122fa5105 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -8773,6 +8773,50 @@ LuaTeX (respectively) is not the engine in use.")
(define-deprecated-package texlive-generic-ifxetex texlive-generic-iftex)
+(define-public texlive-tabu
+ (let ((template
+ (simple-texlive-package
+ "texlive-tabu"
+ (list "doc/latex/tabu/"
+ "source/latex/tabu/"
+ "tex/latex/tabu/")
+ (base32 "0mixyrqavipq4ni38z42x3579cdjbz54cp2qqb4q4yhfbl0a4pka"))))
+ (package
+ (inherit template)
+ (outputs '("out" "doc"))
+ (arguments
+ (substitute-keyword-arguments (package-arguments template)
+ ((#:tex-directory _ '())
+ "latex/tabu")
+ ((#:build-targets _ '())
+ '(list "tabu.dtx"))
+ ((#:phases phases)
+ `(modify-phases ,phases
+ (add-after 'unpack 'chdir
+ (lambda _ (chdir "source/latex/tabu")))
+ (replace 'copy-files
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ (let ((origin (assoc-ref inputs "source"))
+ (source (string-append (assoc-ref outputs "out")
+ "/share/texmf-dist/source"))
+ (doc (string-append (assoc-ref outputs "doc")
+ "/share/texmf-dist/doc")))
+ (copy-recursively (string-append origin "/source") source)
+ (copy-recursively (string-append origin "/doc") doc))))))))
+ (propagated-inputs (list texlive-varwidth))
+ (home-page "https://ctan.org/macros/latex/contrib/tabu")
+ (synopsis "Flexible LaTeX tabulars")
+ (description
+ "The package provides an environment, tabu, which will make any sort of
+tabular, and an environment longtabu which provides the facilities of tabu in
+a modified longtable environment. The package requires array, xcolor for
+coloured rules in tables, and colortbl for coloured cells. The longtabu
+environment further requires that longtable be loaded. The package itself
+does not load any of these packages for the user. The tabu environment may be
+used in place of @code{tabular}, @code{tabular*} and @code{tabularx}
+environments, as well as the @code{array} environment in maths mode.")
+ (license license:lppl1.3+))))
+
(define-public texlive-tools
(let ((template (simple-texlive-package
"texlive-tools"