summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorjgart via Guix-patches via <guix-patches@gnu.org>2022-01-17 22:06:12 -0500
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2022-01-28 10:52:52 +0100
commitd25044f4d2cb277104678bef93cc170d7e0aac5d (patch)
tree00005b049fd883adfbb797454d01bdb9555b3359
parent61f1ec9f60186c23dd609ad3bc569f06c48f3f61 (diff)
downloadguix-patches-d25044f4d2cb277104678bef93cc170d7e0aac5d.tar
guix-patches-d25044f4d2cb277104678bef93cc170d7e0aac5d.tar.gz
gnu: Add go-github-com-go-chi-chi-v5.
* gnu/packages/golang.scm (go-github-com-go-chi-chi-v5): New variable. Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
-rw-r--r--gnu/packages/golang.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index d760f9cda8..4471fea19d 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -9625,3 +9625,26 @@ Features:
@item TCP tunneling (e.g. benchmark with iperf3)
@end itemize")
(license license:asl2.0)))
+
+(define-public go-github-com-go-chi-chi-v5
+ (package
+ (name "go-github-com-go-chi-chi-v5")
+ (version "5.0.7")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/go-chi/chi")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0rzrsxz4xj0973c6nxklvq2vmg2m795snhk25836i0gnd1jnx79k"))))
+ (build-system go-build-system)
+ (arguments
+ '(#:import-path "github.com/go-chi/chi/v5"))
+ (home-page "https://github.com/go-chi/chi")
+ (synopsis "Composable router for HTTP services written in Go")
+ (description
+ "@code{go-github-com-go-chi-chi-v5} is an HTTP router that lets the user
+decompose request handling into many smaller layers.")
+ (license license:expat)))