summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2022-01-28 10:28:59 +0100
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2022-01-28 10:28:59 +0100
commitcd355a8dafb0ccb748ab48604ac3890ba1931e1e (patch)
treedd820aee98f36cebdffdf1d49cc0f56f78fedf2f
parent2f21931833274fb4760cb82203495fab5991877f (diff)
downloadguix-patches-cd355a8dafb0ccb748ab48604ac3890ba1931e1e.tar
guix-patches-cd355a8dafb0ccb748ab48604ac3890ba1931e1e.tar.gz
gnu: Add go-github-com-vmihailenco-tagparser.
* gnu/packages/golang.scm (go-github-com-vmihailenco-tagparser): New variable. Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
-rw-r--r--gnu/packages/golang.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index e808d8ebf6..2990db5ea2 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -8756,6 +8756,28 @@ non-cryptographic hash algorithm, working at speeds close to RAM limits.")
"Provides a platform-independent way to get atime, mtime, ctime and btime for files.")
(license license:expat)))
+(define-public go-github-com-vmihailenco-tagparser
+ (package
+ (name "go-github-com-vmihailenco-tagparser")
+ (version "2.0.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/vmihailenco/tagparser")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "13arliaz3b4bja9jj7cr5ax4zvxaxm484fwrn0q6d6jjm1l35m1k"))))
+ (build-system go-build-system)
+ (arguments
+ '(#:import-path "github.com/vmihailenco/tagparser"))
+ (home-page "https://github.com/vmihailenco/tagparser")
+ (synopsis "Tag parser for Golang")
+ (description "This package is a simple Golang implementation of tag
+parser.")
+ (license license:bsd-2)))
+
(define-public go-github-com-vividcortex-ewma
(package
(name "go-github-com-vividcortex-ewma")