summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPetr Hodina <phodina@protonmail.com>2022-01-11 11:28:17 +0100
committerLudovic Courtès <ludo@gnu.org>2022-01-28 23:40:15 +0100
commit977a6c5769145f86bed96c0c0a9f9ddce76df93d (patch)
treea047b42168c624de8dba9e031d328a46e88a429f
parent476e39e3b2b48a8f388fc129fb6a25ea316ed45a (diff)
downloadguix-patches-977a6c5769145f86bed96c0c0a9f9ddce76df93d.tar
guix-patches-977a6c5769145f86bed96c0c0a9f9ddce76df93d.tar.gz
gnu: Add python-geojson.
* gnu/packages/python-xyz.scm (python-geojson): New variable. Co-authored-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/python-xyz.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index a8aff94334..fc1ff5c80d 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -11642,6 +11642,28 @@ asyncio.")
Python code formatter \"black\".")
(license license:expat)))
+(define-public python-geojson
+ (package
+ (name "python-geojson")
+ (version "2.5.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "geojson" version))
+ (sha256
+ (base32 "12k5bzqskvq3gqzkryarhdjl0df47y5k9cf8r3clasi2wjnbfjvf"))))
+ (build-system python-build-system)
+ (arguments
+ ;; https://github.com/jazzband/geojson/issues/175
+ `(#:tests? #f))
+ (home-page "https://github.com/jazzband/geojson")
+ (synopsis "Python bindings and utilities for GeoJSON")
+ (description
+ "This package provides Python bindings and utilities for
+@uref{http://geojson.org/, GeoJSON}, a format for encoding geographic data
+structures.")
+ (license license:bsd-3)))
+
(define-public python-get-version
(package
(name "python-get-version")