summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2022-01-28 10:44:46 +0100
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2022-01-28 10:44:46 +0100
commit72274434a8419d80d036b9e91af50a291cda644c (patch)
tree413cbb448b5d1d6c2de81e51d1ae035ee682a6bf
parent7c1efe829095230dedfe2b823e03d00c779f25ad (diff)
downloadguix-patches-72274434a8419d80d036b9e91af50a291cda644c.tar
guix-patches-72274434a8419d80d036b9e91af50a291cda644c.tar.gz
gnu: Add go-github-com-andybalholm-brotli.
* gnu/packages/golang.scm (go-github-com-andybalholm-brotli): New variable. Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
-rw-r--r--gnu/packages/golang.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 17f45fac0f..23e36af998 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -3297,6 +3297,32 @@ values for the purpose of fuzz testing.")
incoming requests with their respective handler.")
(license license:bsd-3)))
+(define-public go-github-com-andybalholm-brotli
+ (package
+ (name "go-github-com-andybalholm-brotli")
+ (version "1.0.4")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/andybalholm/brotli")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1zvmj7gbnkq9xwv1bvcxk9acxl06y902148qwbd2kqwgs52wy2c0"))))
+ (build-system go-build-system)
+ (arguments
+ `(#:import-path "github.com/andybalholm/brotli"))
+ (home-page "https://github.com/andybalholm/brotli")
+ (synopsis "Pure Go Brotli encoder and decoder")
+ (description
+ "This package is a brotli compressor and decompressor implemented in Go.
+It was translated from the reference implementation
+(@url{https://github.com/google/brotli,https://github.com/google/brotli}) with
+the @code{c2go} tool at
+@url{https://github.com/andybalholm/c2go,https://github.com/andybalholm/c2go}.")
+ (license license:expat)))
+
(define-public go-github-com-gorilla-handlers
(package
(name "go-github-com-gorilla-handlers")