summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2022-01-28 10:36:01 +0100
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2022-01-28 10:36:01 +0100
commit63b194080d3038bdfc54d66355bdd59e86197214 (patch)
tree8528d79119d0b53d47c2ce2da648b452389bd560
parenta222ae9146404e6d04276682a0a5ad4fe4bc6743 (diff)
downloadguix-patches-63b194080d3038bdfc54d66355bdd59e86197214.tar
guix-patches-63b194080d3038bdfc54d66355bdd59e86197214.tar.gz
gnu: Add go-github-com-hashicorp-hcl-v2.
* gnu/packages/golang.scm (go-github-com-hashicorp-hcl-v2): New variable. Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
-rw-r--r--gnu/packages/golang.scm31
1 files changed, 31 insertions, 0 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index b58c84787d..62e5127239 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -2456,6 +2456,37 @@ expressing configuration which is easy for both humans and machines to read.")
(home-page "https://github.com/hashicorp/hcl")
(license license:mpl2.0)))
+(define-public go-github-com-hashicorp-hcl-v2
+ (package
+ (name "go-github-com-hashicorp-hcl-v2")
+ (version "2.11.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/hashicorp/hcl")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0f9flmmkj7fr1337fc56cqy73faq87ix375hnz3id4wc023przv1"))))
+ (build-system go-build-system)
+ (arguments
+ '(#:import-path "github.com/hashicorp/hcl/v2"))
+ (native-inputs
+ (list go-github-com-davecgh-go-spew))
+ (inputs
+ (list go-github-com-agext-levenshtein go-github-com-mitchellh-go-wordwrap
+ go-github-com-zclconf-go-cty
+ go-github-com-apparentlymart-go-textseg-v13))
+ (synopsis "Go implementation of HashiCorp Configuration Language V2")
+ (description
+ "This package contains the main implementation of the @acronym{HCL,
+HashiCorp Configuration Language}. HCL is designed to be a language for
+expressing configuration which is easy for both humans and machines to read.")
+ (home-page "https://github.com/hashicorp/hcl")
+ (license license:mpl2.0)))
+
(define-public go-golang-org-x-tools
(let ((commit "8b927904ee0dec805c89aaf9172f4459296ed6e8")
(revision "0"))