summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2022-01-28 10:47:21 +0100
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2022-01-28 10:47:21 +0100
commit61f1ec9f60186c23dd609ad3bc569f06c48f3f61 (patch)
tree71e2a77416668da25d33a39eb3cec2f3de680501
parent0467ecbe0dda4aead3afdabf7a29e4143d6afa17 (diff)
downloadguix-patches-61f1ec9f60186c23dd609ad3bc569f06c48f3f61.tar
guix-patches-61f1ec9f60186c23dd609ad3bc569f06c48f3f61.tar.gz
gnu: Add go-github-com-valyala-fasthttp.
* gnu/packages/golang.scm (go-github-com-valyala-fasthttp): New variable. Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
-rw-r--r--gnu/packages/golang.scm31
1 files changed, 31 insertions, 0 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index bf8c1445f0..d760f9cda8 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -8929,6 +8929,37 @@ non-cryptographic hash algorithm, working at speeds close to RAM limits.")
anti-fragmentation protection.")
(license license:expat)))
+(define-public go-github-com-valyala-fasthttp
+ (package
+ (name "go-github-com-valyala-fasthttp")
+ (version "1.31.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/valyala/fasthttp")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0ra0n2shcp11736xv37cjnsqn32gvqfm3dkf9v8j98xmch2wqxqg"))))
+ (build-system go-build-system)
+ (arguments
+ '(#:import-path "github.com/valyala/fasthttp"))
+ (propagated-inputs
+ (list go-golang-org-x-sys
+ go-golang-org-x-net
+ go-golang-org-x-crypto
+ go-github-com-valyala-tcplisten
+ go-github-com-valyala-bytebufferpool
+ go-github-com-klauspost-compress
+ go-github-com-andybalholm-brotli))
+ (home-page "https://github.com/valyala/fasthttp")
+ (synopsis "Provides fast HTTP server and client API")
+ (description
+ "This package provides a Go module @code{fasthttp} which may be used as
+replacement for native @code{net/http} module.")
+ (license license:expat)))
+
(define-public go-github-com-valyala-tcplisten
(package
(name "go-github-com-valyala-tcplisten")