summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2022-01-28 16:47:55 +0100
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2022-01-28 16:47:55 +0100
commit5c1a1cecaa17f4c1e16d13891f36b4ec0b998cec (patch)
treea56a4ce2ea5233446bd41f12ad9454d7e0cf93d6
parenta057d2acbf8d78afe474669fea29adef6aa949cc (diff)
downloadguix-patches-5c1a1cecaa17f4c1e16d13891f36b4ec0b998cec.tar
guix-patches-5c1a1cecaa17f4c1e16d13891f36b4ec0b998cec.tar.gz
gnu: Add texlive-varwidth.
* gnu/packages/tex.scm (texlive-varwidth): New variable.
-rw-r--r--gnu/packages/tex.scm15
1 files changed, 15 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index f332f231b7..d263be630d 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -6924,6 +6924,21 @@ Association for Computing Machinery (ACM).")
get a narrower “natural” width.")
(license license:lppl)))
+(define-public texlive-varwidth
+ (package
+ (inherit (simple-texlive-package
+ "texlive-varwidth"
+ (list "doc/latex/varwidth/" "tex/latex/varwidth/")
+ (base32 "0jcrv4klcjpl17ml0zyqfvkrq6qwn2imxv8syqs5m6qk0fk7hg6l")
+ #:trivial? #t))
+ (home-page "https://ctan.org/macros/latex/contrib/varwidth")
+ (synopsis "Variable-width minipage LaTeX environment")
+ (description
+ "The varwidth environment is superficially similar to minipage, but the
+specified width is just a maximum value --- the box may get a narrower natural
+width.")
+ (license license:lppl)))
+
(define-public texlive-wasy
(package
(inherit (simple-texlive-package