summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2022-01-28 10:33:16 +0100
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2022-01-28 10:33:16 +0100
commit52850033d37ea2153210974acbb969b616d3ba20 (patch)
treebdebcb0ab7206ae8e153bda540bda4e08f049926
parent433f04136b443cb935a0911fa7560fa87f029e64 (diff)
downloadguix-patches-52850033d37ea2153210974acbb969b616d3ba20.tar
guix-patches-52850033d37ea2153210974acbb969b616d3ba20.tar.gz
gnu: Add go-github-com-agext-levenshtein.
* gnu/packages/golang.scm (go-github-com-agext-levenshtein): New variable. Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
-rw-r--r--gnu/packages/golang.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 4ff4d8c3ff..560a1a6938 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -899,6 +899,29 @@ network traffic so that it is not identified and subsequently blocked by network
filtering devices.")
(license license:bsd-2))))
+(define-public go-github-com-agext-levenshtein
+ (package
+ (name "go-github-com-agext-levenshtein")
+ (version "1.2.3")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/agext/levenshtein")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0a26c8pp9h5w66bhd9vb6lpvmhp30mz46pnh3a8vrjx50givb2lw"))))
+ (build-system go-build-system)
+ (arguments
+ '(#:import-path "github.com/agext/levenshtein"))
+ (home-page "https://github.com/agext/levenshtein")
+ (synopsis "Calculating the Levenshtein distance between two strings in Go")
+ (description
+ "Package levenshtein implements distance and similarity metrics for
+strings, based on the Levenshtein measure.")
+ (license license:asl2.0)))
+
(define-public go-github-com-apparentlymart-go-textseg-v13
(package
(name "go-github-com-apparentlymart-go-textseg-v13")