summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2022-01-28 10:37:09 +0100
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2022-01-28 10:37:09 +0100
commit4db80f3f0cc32d4f6a487cb51a3ac393694affe3 (patch)
tree83b4ec30ca69824b41a37071034a17c29d005c48
parent63b194080d3038bdfc54d66355bdd59e86197214 (diff)
downloadguix-patches-4db80f3f0cc32d4f6a487cb51a3ac393694affe3.tar
guix-patches-4db80f3f0cc32d4f6a487cb51a3ac393694affe3.tar.gz
gnu: Add go-github-com-vmihailenco-msgpack-v4.
* gnu/packages/golang.scm (go-github-com-vmihailenco-msgpack-v4): New variable. Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
-rw-r--r--gnu/packages/golang.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 62e5127239..a919d37590 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -8879,6 +8879,33 @@ non-cryptographic hash algorithm, working at speeds close to RAM limits.")
"Provides a platform-independent way to get atime, mtime, ctime and btime for files.")
(license license:expat)))
+(define-public go-github-com-vmihailenco-msgpack-v4
+ (package
+ (name "go-github-com-vmihailenco-msgpack-v4")
+ (version "4.3.12")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/vmihailenco/msgpack")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0aiavk7b5fn050bbc0naldk2bsl60f8wil5i6a1cfp3lxxnvmvng"))))
+ (build-system go-build-system)
+ (arguments
+ '(#:import-path "github.com/vmihailenco/msgpack/v4"))
+ (native-inputs
+ (list go-gopkg-in-check-v1))
+ (propagated-inputs
+ (list go-github-com-vmihailenco-tagparser))
+ (home-page "https://github.com/vmihailenco/msgpack")
+ (synopsis "MessagePack encoding for Golang")
+ (description
+ "This package provides implementation of MessagePack encoding for Go
+programming language.")
+ (license license:bsd-2)))
+
(define-public go-github-com-vmihailenco-tagparser
(package
(name "go-github-com-vmihailenco-tagparser")