summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2022-01-28 23:26:37 +0100
committerLudovic Courtès <ludo@gnu.org>2022-01-28 23:26:37 +0100
commit476e39e3b2b48a8f388fc129fb6a25ea316ed45a (patch)
treebb522755e5f4237031f4c4250442693c0a7270dd
parent47bb5779ba977acc0e016e94239523fcbd68c5a1 (diff)
downloadguix-patches-476e39e3b2b48a8f388fc129fb6a25ea316ed45a.tar
guix-patches-476e39e3b2b48a8f388fc129fb6a25ea316ed45a.tar.gz
gnu: Add texlive-textcase.
* gnu/packages/tex.scm (texlive-textcase): New variable.
-rw-r--r--gnu/packages/tex.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 67b5b70d94..5ee1c3e071 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -5495,6 +5495,33 @@ other programs in the distribution offer online interactive use (with
hypertext linkages in some cases).")
(license license:gpl3+)))
+(define-public texlive-textcase
+ (package
+ (inherit (simple-texlive-package
+ "texlive-textcase"
+ (list "doc/latex/textcase/"
+ "tex/latex/textcase/"
+ "source/latex/textcase/")
+ (base32
+ "185fibd41wd0v51gnai29ygi32snkk00p00110kcnk1bcnmpiw82")
+ #:trivial? #t))
+ (home-page "https://ctan.org/macros/latex/contrib/textcase")
+ (synopsis "Case conversion ignoring mathematics, etc")
+ (description
+ "The textcase package offers commands @code{\\MakeTextUppercase} and
+@code{\\MakeTextLowercase} are similar to the standard @code{\\MakeUppercase}
+and @code{\\MakeLowercase}, but they do not change the case of any sections of
+mathematics, or the arguments of @code{\\cite}, @code{\\label} and
+@code{\\ref} commands within the argument. A further command
+@code{\\NoCaseChange} does nothing but suppress case change within its
+argument, so to force uppercase of a section including an environment, one
+might say:
+
+@example
+\\MakeTextUppercase{...\\NoCaseChange{\\begin{foo}} ...\\NoCaseChange{\\end{foo}}...}
+@end example\n")
+ (license license:lppl)))
+
(define-public texlive-latex-upquote
(package
(name "texlive-latex-upquote")