summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2022-01-28 12:34:58 -0500
committerLeo Famulari <leo@famulari.name>2022-01-28 14:03:03 -0500
commit229759833dbde298d6ab44818f1c6bc140865a33 (patch)
tree173c3b80f505445d6d2324fcfcaf5c2d9aedc4f0
parent262a1734e250f756471a066348381017b3e281d6 (diff)
downloadguix-patches-229759833dbde298d6ab44818f1c6bc140865a33.tar
guix-patches-229759833dbde298d6ab44818f1c6bc140865a33.tar.gz
gnu: Calibre: Remove a transitive dependency on QtWebKit.
See <https://issues.guix.gnu.org/53289> for more information about this change. * gnu/packages/ebook.scm (calibre)[inputs]: Replace python-pyqt with python-pyqt-without-qtwebkit. [arguments]: Adjust the custom 'configure' phase accordingly.
-rw-r--r--gnu/packages/ebook.scm4
1 files changed, 2 insertions, 2 deletions
diff --git a/gnu/packages/ebook.scm b/gnu/packages/ebook.scm
index 207bbfcdaf..0875dae190 100644
--- a/gnu/packages/ebook.scm
+++ b/gnu/packages/ebook.scm
@@ -198,7 +198,7 @@ with Microsoft Compiled HTML (CHM) files")
("python-pychm" ,python-pychm)
("python-pycryptodome" ,python-pycryptodome)
("python-pygments" ,python-pygments)
- ("python-pyqt" ,python-pyqt)
+ ("python-pyqt-without-qtwebkit" ,python-pyqt-without-qtwebkit)
("python-pyqtwebengine" ,python-pyqtwebengine)
("python-regex" ,python-regex)
("python-speechd" ,speech-dispatcher)
@@ -238,7 +238,7 @@ with Microsoft Compiled HTML (CHM) files")
(add-before 'build 'configure
(lambda* (#:key inputs outputs #:allow-other-keys)
(let ((podofo (assoc-ref inputs "podofo"))
- (pyqt (assoc-ref inputs "python-pyqt"))
+ (pyqt (assoc-ref inputs "python-pyqt-without-qtwebkit"))
(python-sip (assoc-ref inputs "python-sip"))
(out (assoc-ref outputs "out")))
(substitute* "setup/build.py"