summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2022-01-28 23:21:06 +0100
committerLudovic Courtès <ludo@gnu.org>2022-01-28 23:21:06 +0100
commit0c2e1b0d9cb0941d2820ae113451346976246319 (patch)
tree032e01749b21e636191a3cb697a6453809f7b228
parent25ead7941f2085b3ac40c3ba2cc6afb2946ade2a (diff)
downloadguix-patches-0c2e1b0d9cb0941d2820ae113451346976246319.tar
guix-patches-0c2e1b0d9cb0941d2820ae113451346976246319.tar.gz
gnu: Add texlive-inputenx.
* gnu/packages/tex.scm (texlive-inputenx): New variable.
-rw-r--r--gnu/packages/tex.scm19
1 files changed, 19 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index be2d433ce0..e58ec5975d 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -2775,6 +2775,25 @@ patterns supporting a number of Cyrillic font encodings, including T2,
UCY (Omega Unicode Cyrillic), LCY, LWN (OT2), and koi8-r.")
(license license:lppl))))
+(define-public texlive-inputenx
+ (package
+ (inherit (simple-texlive-package
+ "texlive-inputenx"
+ (list "doc/latex/inputenx/"
+ "tex/latex/inputenx/"
+ "source/latex/inputenx/")
+ (base32
+ "0snjndrcynm4w8m9iq8gmadzhrbwvsdy4y1ak24ia0hpsicdi4aj")
+ #:trivial? #t))
+ (home-page "https://ctan.org/macros/latex/contrib/inputenx")
+ (synopsis "Enhanced input encoding handling")
+ (description
+ "This package deals with input encodings. It provides a wider range of input
+encodings using standard mappings, than does inputenc; it also covers nearly all
+slots. In this way, it serves as more uptodate replacement for package
+inputenc.")
+ (license license:lppl1.3+)))
+
(define-public texlive-kpathsea
(let ((template (simple-texlive-package
"texlive-kpathsea"