summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuix Together <jgart@dismail.de>2021-07-31 20:29:07 -0400
committerEfraim Flashner <efraim@flashner.co.il>2021-08-04 10:56:07 +0300
commitd3ede451cf1043ef2131813a0479775ef80c808c (patch)
treedc09bbcfa6bead71e4e45cfa223ba2e89c5dad17
parente7d32b4bccc2f0f390cd4efbdc86556ffe6a63d5 (diff)
downloadguix-patches-d3ede451cf1043ef2131813a0479775ef80c808c.tar
guix-patches-d3ede451cf1043ef2131813a0479775ef80c808c.tar.gz
gnu: Add bitwise.
* gnu/packages/maths.scm (bitwise): New variable. Co-authored-by: jgart <jgart@dismail.de> Co-authored-by: Julien Lepiller <julien@lepiller.eu> Co-authored-by: Ryan Prior <rprior@protonmail.com> Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
-rw-r--r--gnu/packages/maths.scm34
1 files changed, 34 insertions, 0 deletions
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index 1afe72659a..b2b3150ca2 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -124,6 +124,7 @@
#:use-module (gnu packages m4)
#:use-module (gnu packages mpi)
#:use-module (gnu packages multiprecision)
+ #:use-module (gnu packages ncurses)
#:use-module (gnu packages netpbm)
#:use-module (gnu packages ocaml)
#:use-module (gnu packages onc-rpc)
@@ -175,6 +176,39 @@ beginners.")
(license license:gpl3+)
(home-page "https://www.gnu.org/software/aris/")))
+(define-public bitwise
+ (package
+ (name "bitwise")
+ (version "0.42")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/mellowcandle/bitwise"
+ "/releases/download/v" version
+ "/bitwise-v" version ".tar.gz"))
+ (sha256
+ (base32 "1lniw4bsb5qs5ybf018qllf95pzixb1q3lvybzl4k3xz8zpkrm6k"))))
+ (build-system gnu-build-system)
+ (inputs
+ `(("ncurses" ,ncurses)
+ ("readline" ,readline)))
+ (native-inputs
+ `(("cunit" ,cunit)
+ ("pkg-config" ,pkg-config)))
+ (synopsis "Terminal based bit manipulator in ncurses")
+ (description "Bitwise is a multi base interactive calculator supporting
+dynamic base conversion and bit manipulation. It's a handy tool for low level
+hackers, kernel developers and device drivers developers.
+
+Some of the features include:
+@itemize
+@item Interactive ncurses interface.
+@item Command line calculator supporting all bitwise operations.
+@item Individual bit manipulator.
+@item Bitwise operations such as NOT, OR, AND, XOR, and shifts.
+@end itemize")
+ (license license:gpl3+)
+ (home-page "https://github.com/mellowcandle/bitwise/")))
+
(define-public c-graph
(package
(name "c-graph")