summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2016-12-07 15:31:56 +0100
committerMarius Bakke <mbakke@fastmail.com>2016-12-13 09:37:43 +0100
commitad04bd6b2a3274222a5a618fd8d7927ea0bf1b1c (patch)
tree31648a1590cdcaf0c65c1c3071637140de7c6630
parentff55fe559951b88bfd691b9dada3a0f26002c4cb (diff)
downloadguix-patches-ad04bd6b2a3274222a5a618fd8d7927ea0bf1b1c.tar
guix-patches-ad04bd6b2a3274222a5a618fd8d7927ea0bf1b1c.tar.gz
gnu: duplicity: Use 'modify-phases' syntax.
* gnu/packages/backup.scm (duplicity)[arguments]: Use 'modify-phases'.
-rw-r--r--gnu/packages/backup.scm21
1 files changed, 11 insertions, 10 deletions
diff --git a/gnu/packages/backup.scm b/gnu/packages/backup.scm
index a503b06603..6f88dae789 100644
--- a/gnu/packages/backup.scm
+++ b/gnu/packages/backup.scm
@@ -78,16 +78,17 @@
(arguments
`(#:python ,python-2 ;setup assumes Python 2
#:test-target "test"
- #:phases (alist-cons-before
- 'check 'check-setup
- (lambda* (#:key inputs #:allow-other-keys)
- (substitute* "testing/functional/__init__.py"
- (("/bin/sh") (which "sh")))
- (setenv "HOME" (getcwd)) ;gpg needs to write to $HOME
- (setenv "TZDIR" ;some timestamp checks need TZDIR
- (string-append (assoc-ref inputs "tzdata")
- "/share/zoneinfo")))
- %standard-phases)))
+ #:phases
+ (modify-phases %standard-phases
+ (add-before 'check 'check-setup
+ (lambda* (#:key inputs #:allow-other-keys)
+ (substitute* "testing/functional/__init__.py"
+ (("/bin/sh") (which "sh")))
+ (setenv "HOME" (getcwd)) ;gpg needs to write to $HOME
+ (setenv "TZDIR" ;some timestamp checks need TZDIR
+ (string-append (assoc-ref inputs "tzdata")
+ "/share/zoneinfo"))
+ #t)))))
(home-page "http://duplicity.nongnu.org/index.html")
(synopsis "Encrypted backup using rsync algorithm")
(description