summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2019-11-29 14:25:41 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2019-11-29 14:39:36 +0100
commit8c3f2170c433ae01f52fd5bcaad61a729b8f9a5e (patch)
tree7776597c11b2ede04989c52527e77a36434a8ef6
parent757e40279203d5cfa0ff212c4ba2af4d1b6913ad (diff)
downloadguix-patches-8c3f2170c433ae01f52fd5bcaad61a729b8f9a5e.tar
guix-patches-8c3f2170c433ae01f52fd5bcaad61a729b8f9a5e.tar.gz
gnu: moka-icon-theme: Don't use unstable tarball.
* gnu/packages/gnome.scm (moka-icon-theme)[source]: Use GIT-FETCH and GIT-FILE-NAME, and follow upstream redirection.
-rw-r--r--gnu/packages/gnome.scm18
1 files changed, 9 insertions, 9 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 04a891d79c..96a46ab964 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -7203,15 +7203,15 @@ Moka")
(inherit faba-icon-theme)
(name "moka-icon-theme")
(version "5.4.0")
- (source (origin
- (method url-fetch)
- (uri (string-append "https://github.com/moka-project"
- "/moka-icon-theme/archive/v"
- version ".tar.gz"))
- (file-name (string-append name "-" version ".tar.gz"))
- (sha256
- (base32
- "1nbwdjj268hxv9lfagd9aylily9f0hhallp841v0i3imljp84bmk"))))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/snwh/moka-icon-theme.git")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "015l02im4mha5z91dbchxf6xkp66d346bg3xskwg0rh3lglhjsrd"))))
(propagated-inputs
;; Moka is based on Faba by using it as a fallback icon set instead of
;; bundling it, so we need to add it as a propagated input.