summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Rohleder <mike@rohleder.de>2022-01-27 09:15:53 +0100
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2022-01-28 09:35:41 +0100
commit8473a9f3b4be389f38c7aa8afb69369f66e699a7 (patch)
tree708129ba181aeb92d80f0234fd8abb212020cd91
parent868df4f36f687b16c7b5fda99a4edfbb71d85507 (diff)
downloadguix-patches-8473a9f3b4be389f38c7aa8afb69369f66e699a7.tar
guix-patches-8473a9f3b4be389f38c7aa8afb69369f66e699a7.tar.gz
gnu: emacs-diminish: Update to 0.46-1.fd486ef.
* gnu/packages/emacs-xyz.scm (emacs-diminish): Update to 0.46-1.fd486ef. [license]: Change from gpl2+ to gpl3+. Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
-rw-r--r--gnu/packages/emacs-xyz.scm36
1 files changed, 19 insertions, 17 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index d6b8dcbb0d..b2da1430f1 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -13412,24 +13412,26 @@ the hunks and revert them selectively.")
(license license:gpl3+)))
(define-public emacs-diminish
- (package
- (name "emacs-diminish")
- (version "0.45")
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/myrjola/diminish.el")
- (commit (string-append "v" version))))
- (file-name (git-file-name name version))
- (sha256
- (base32 "0qpgfgp8hrzz4vdifxq8h25n0a0jlzgf7aa1fpy6r0080v5rqbb6"))))
- (build-system emacs-build-system)
- (home-page "https://github.com/myrjola/diminish.el")
- (synopsis "Diminish minor modes with no modeline display")
- (description "@code{emacs-diminish} implements hiding or
+ (let ((commit "fd486ef76e4c1d8211ae337a43b8bba106d4bca7")
+ (revision "1"))
+ (package
+ (name "emacs-diminish")
+ (version (git-version "0.46" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/myrjola/diminish.el")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1vlgn7swwfzy6yr880698h3qsmfcqprcb1jvffkzmbvhvf458szf"))))
+ (build-system emacs-build-system)
+ (home-page "https://github.com/myrjola/diminish.el")
+ (synopsis "Diminish minor modes with no modeline display")
+ (description "@code{emacs-diminish} implements hiding or
abbreviation of the mode line displays (lighters) of minor modes.")
- (license license:gpl2+)))
+ (license license:gpl3+))))
(define-public emacs-use-package
(package