summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBjörn Höfling <bjoern.hoefling@bjoernhoefling.de>2019-09-17 23:05:18 +0200
committerBjörn Höfling <bjoern.hoefling@bjoernhoefling.de>2019-09-17 23:12:01 +0200
commit7026ecc122c6470b9a2fbb88d4448a74b948647e (patch)
tree22e3fde570b7243c587820b3837c0635e0d9352f
parent3a8d68badaca85122d91d8b7045daee87acb0aea (diff)
downloadguix-patches-7026ecc122c6470b9a2fbb88d4448a74b948647e.tar
guix-patches-7026ecc122c6470b9a2fbb88d4448a74b948647e.tar.gz
gnu: emacs-olivetti: Update to 1.8.0.
* gnu/packages/emacs-xyz.scm (emacs-olivetti)[version]: Update to 1.8.0. [source]: Use github instead of melpa.
-rw-r--r--gnu/packages/emacs-xyz.scm13
1 files changed, 7 insertions, 6 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 28443ae7fd..d684426091 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -2126,15 +2126,16 @@ a command.")
(define-public emacs-olivetti
(package
(name "emacs-olivetti")
- (version "1.5.7")
+ (version "1.8.0")
(source (origin
- (method url-fetch)
- (uri (string-append
- "https://stable.melpa.org/packages/olivetti-"
- version ".el"))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/rnkn/olivetti.git")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
(sha256
(base32
- "1yj2ylg46q0pw1xzlv2b0fv9x8p56x25284s9v2smwjr4vf0nwcj"))))
+ "0ba30swqxxbpa8866chymywnahby1hk670zzkz44q49328i2wksj"))))
(build-system emacs-build-system)
(home-page "https://github.com/rnkn/olivetti")
(synopsis "Emacs minor mode for a nice writing environment")