summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2019-09-17 16:51:08 +0300
committerEfraim Flashner <efraim@flashner.co.il>2019-09-17 19:40:08 +0300
commit5e9fdf91896ae03d86cb1c5c98768b8d598646db (patch)
tree75d7aea9203efcdc9107b6b5631165e9cf44f426
parenta7debf9d7f655493e6c22936df6ade5d20a34ec6 (diff)
downloadguix-patches-5e9fdf91896ae03d86cb1c5c98768b8d598646db.tar
guix-patches-5e9fdf91896ae03d86cb1c5c98768b8d598646db.tar.gz
gnu: Add rust-openssl-src.
* gnu/packages/crates-io.scm (rust-openssl-src): New variable.
-rw-r--r--gnu/packages/crates-io.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 7aa5289a29..71c69a5d66 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -2189,6 +2189,28 @@ system for OpenSSL.")
(license (list license:asl2.0
license:expat))))
+(define-public rust-openssl-src
+ (package
+ (name "rust-openssl-src")
+ (version "111.6.0+1.1.1d")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "openssl-src" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "172xh95hp7aygahah1940kg1dnx60c5m80cwj5hgi8x7x0fxmhmr"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:cargo-inputs (("rust-cc" ,rust-cc))))
+ (home-page "https://github.com/alexcrichton/openssl-src-rs")
+ (synopsis "Source of OpenSSL for rust crates")
+ (description
+ "This package contains the source of OpenSSL and logic to build it.")
+ (license (list license:asl2.0
+ license:expat))))
+
(define-public rust-owning-ref
(package
(name "rust-owning-ref")