summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBjörn Höfling <bjoern.hoefling@bjoernhoefling.de>2019-09-17 22:23:42 +0200
committerBjörn Höfling <bjoern.hoefling@bjoernhoefling.de>2019-09-17 22:23:42 +0200
commit3a8d68badaca85122d91d8b7045daee87acb0aea (patch)
tree3d1609aca4efe8de4cd1e3d2269de540ee8f4e2d
parent17bbd30d877cb361e6236ccb0e6b3166452f9214 (diff)
downloadguix-patches-3a8d68badaca85122d91d8b7045daee87acb0aea.tar
guix-patches-3a8d68badaca85122d91d8b7045daee87acb0aea.tar.gz
gnu: emacs-elixir-mode: Use git-fetch.
Fixes a source instability reported by Josh Holland in <https://debbugs.gnu.org/cgi/bugreport.cgi?bug=37437> * gnu/packages/emacs-xyz.scm (emacs-elixir-mode)[source]: Use GIT-FETCH & GIT-FILE-NAME.
-rw-r--r--gnu/packages/emacs-xyz.scm14
1 files changed, 7 insertions, 7 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index b2f057a439..28443ae7fd 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -53,6 +53,7 @@
;;; Copyright © 2019 Jens Mølgaard <jens@zete.tk>
;;; Copyright © 2019 Amin Bandali <bandali@gnu.org>
;;; Copyright © 2019 Jelle Licht <jlicht@fsfe.org>
+;;; Copyright © 2019 Björn Höfling <bjoern.hoefling@bjoernhoefling.de>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -18241,14 +18242,13 @@ Emacs that integrate with major modes like Org-mode.")
(version "2.3.1")
(source
(origin
- (method url-fetch)
- (uri (string-append
- "https://stable.melpa.org/packages/elixir-mode-"
- version
- ".tar"))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/elixir-editors/emacs-elixir.git")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
(sha256
- (base32
- "091cizxg1aw8bkj58y048mj020ssapjflav633z9bl6gmi10dy4v"))))
+ (base32 "06bi68x49v6f7flpz279mm4jpg31ll3s274givm3pvr8slcxs6xg"))))
(build-system emacs-build-system)
(propagated-inputs
`(("emacs-pkg-info" ,emacs-pkg-info)))