summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTaiju HIGASHI <higashi@taiju.info>2022-01-07 00:21:45 +0900
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2022-01-07 21:16:43 +0100
commit3a08655d59d857a2aeb03d4215df659e19ee4cff (patch)
treeb5352fdce5e50246911ccc18cec645b0123964ea
parent4a943cfdbe42d77a0a11ee8fa8f5c616a97e0911 (diff)
downloadguix-patches-3a08655d59d857a2aeb03d4215df659e19ee4cff.tar
guix-patches-3a08655d59d857a2aeb03d4215df659e19ee4cff.tar.gz
gnu: Add emacs-ox-gfm.
* gnu/packages/emacs-xyz.scm (emacs-ox-gfm): New variable. Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
-rw-r--r--gnu/packages/emacs-xyz.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 9e7dcc6cf9..4d6d1e23ab 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -105,6 +105,7 @@
;;; Copyright © 2021 Simon South <simon@simonsouth.net>
;;; Copyright © 2021 la snesne <lasnesne@lagunposprasihopre.org>
;;; Copyright © 2021 Brian Kubisiak <brian@kubisiak.com>
+;;; Copyright © 2021, 2022 Taiju HIGASHI <higashi@taiju.info>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -7953,6 +7954,26 @@ a LaTeX file, which compiles into a nice CV. In the same spirit, the Org file
may export to Markdown so that it can be used for a web based CV.")
(license license:gpl3+))))
+(define-public emacs-ox-gfm
+ (package
+ (name "emacs-ox-gfm")
+ (version "1.0")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/larstvei/ox-gfm")
+ (commit (string-append "v" version))))
+ (sha256
+ (base32
+ "0drdypmgxk3238hmkqw9s3cw9wv94cyfqar5ar0bv0k69s92pxj8"))))
+ (build-system emacs-build-system)
+ (home-page "https://github.com/larstvei/ox-gfm")
+ (synopsis "Github Flavored Markdown Back-End for Org Export Engine")
+ (description "This package is a small exporter based on the Markdown
+exporter already existing in Org mode. It supports the Github flavored
+markdown features.")
+ (license license:gpl3+)))
+
(define-public emacs-2048-game
(package
(name "emacs-2048-game")