summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArun Isaac <arunisaac@systemreboot.net>2021-07-09 12:31:02 +0530
committerArun Isaac <arunisaac@systemreboot.net>2021-08-01 19:20:21 +0530
commit344460bab44ec3473877089983e4a5b518b9c9d5 (patch)
tree7795e686ef639752a4b03f0c7bb490e82a83c068
parentfcba63f8b7806493fc5060b267af93cdb7d21aa6 (diff)
downloadguix-patches-344460bab44ec3473877089983e4a5b518b9c9d5.tar
guix-patches-344460bab44ec3473877089983e4a5b518b9c9d5.tar.gz
gnu: Add go-github-com-davecgh-go-xdr.
* gnu/packages/golang.scm (go-github-com-davecgh-go-xdr): New variable.
-rw-r--r--gnu/packages/golang.scm27
1 files changed, 26 insertions, 1 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index a830afa022..cbce7bec41 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -15,7 +15,7 @@
;;; Copyright © 2018, 2019, 2020 Katherine Cox-Buday <cox.katherine.e@gmail.com>
;;; Copyright © 2019 Giovanni Biscuolo <g@xelera.eu>
;;; Copyright © 2019, 2020 Alex Griffin <a@ajgrf.com>
-;;; Copyright © 2019, 2020 Arun Isaac <arunisaac@systemreboot.net>
+;;; Copyright © 2019, 2020, 2021 Arun Isaac <arunisaac@systemreboot.net>
;;; Copyright © 2020 Jack Hill <jackhill@jackhill.us>
;;; Copyright © 2020 Jakub Kądziołka <kuba@kadziolka.net>
;;; Copyright © 2020 Nicolas Goaziou <mail@nicolasgoaziou.com>
@@ -8224,3 +8224,28 @@ simplifications, and enforces style rules.")
"This package provides a library for fast, structured, leveled logging in
Go.")
(license license:expat)))
+
+(define-public go-github-com-davecgh-go-xdr
+ (package
+ (name "go-github-com-davecgh-go-xdr")
+ (version "0.0.0-20161123171359-e6a2ba005892")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/davecgh/go-xdr")
+ (commit (go-version->git-ref version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0vifrz4iil4r7k8sz5iqlfbh80ysgs5abp2simgyhsbrkxrrsrrd"))))
+ (build-system go-build-system)
+ (arguments
+ '(#:import-path "github.com/davecgh/go-xdr/xdr2"
+ #:unpack-path "github.com/davecgh/go-xdr"))
+ (home-page "https://github.com/davecgh/go-xdr")
+ (synopsis "Pure Go implementation of the XDR standard")
+ (description "@code{go-xdr} implements the data representation portion of
+the External Data Representation (XDR) standard protocol as specified in RFC
+4506 (obsoletes RFC 1832 and RFC 1014) in pure Go.")
+ (license license:isc)))