summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
author宋文武 <iyzsong@gmail.com>2016-06-23 23:09:03 +0800
committer宋文武 <iyzsong@gmail.com>2016-06-25 20:49:59 +0800
commit1899556655dda2dbffcf5e76f8f2796d64e37a20 (patch)
tree32394bd41265481ed8dffeb0adcf7e8580586dea
parent1f2b62a4fa6953eabce5b37462ee7de179cda71b (diff)
downloadguix-patches-1899556655dda2dbffcf5e76f8f2796d64e37a20.tar
guix-patches-1899556655dda2dbffcf5e76f8f2796d64e37a20.tar.gz
gnu: Add python-pylev and python2-pylev.
* gnu/packages/python.scm (python-pylev, python2-pylev): New variables.
-rw-r--r--gnu/packages/python.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index ced8232061..1dc521220e 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -9368,3 +9368,26 @@ underscored string.")
(define-public python2-inflection
(package-with-python2 python-inflection))
+(define-public python-pylev
+ (package
+ (name "python-pylev")
+ (version "1.3.0")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "pylev" version))
+ (sha256
+ (base32
+ "1hz1x9blsbxya1y9nnhnwwdnqmakxi9mc0jkwj0rn6b1h44i0f86"))))
+ (build-system python-build-system)
+ (native-inputs
+ `(("python-setuptools" ,python-setuptools)))
+ (home-page "http://github.com/toastdriven/pylev")
+ (synopsis "Levenshtein distance implementation in Python")
+ (description "Pure Python Levenshtein implementation, based off the
+Wikipedia code samples at
+@url{http://en.wikipedia.org/wiki/Levenshtein_distance}.")
+ (license bsd-3)))
+
+(define-public python2-pylev
+ (package-with-python2 python-pylev))
+