summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStephen Paul Weber <singpolyma@singpolyma.net>2021-10-18 12:48:31 -0500
committerLudovic Courtès <ludo@gnu.org>2021-11-23 10:24:26 +0100
commit135161ded936e206d5e5c307dc69c1a50b53f27b (patch)
tree0c18e949300767c3af66722f25aefba0dbbf4e43
parent54223d262c8a9c3b10e4358dee021714e409c87b (diff)
downloadguix-patches-135161ded936e206d5e5c307dc69c1a50b53f27b.tar
guix-patches-135161ded936e206d5e5c307dc69c1a50b53f27b.tar.gz
gnu: Add python-dbus-next.
* gnu/packages/python-xyz.scm (python-debus-next): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/python-xyz.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index abcb36e9bb..00204123ea 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -8964,6 +8964,31 @@ implementation of D-Bus.")
(package-inputs python-dbus)
equal?)))))
+(define-public python-dbus-next
+ (package
+ (name "python-dbus-next")
+ (version "0.2.3")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/altdesktop/python-dbus-next")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1ahaz52kny1p9xxv6phvk4iq56rg8li390wywlxf2yslaij1188h"))))
+ (build-system python-build-system)
+ (native-inputs
+ `(("python-pytest" ,python-pytest)))
+ (home-page "https://github.com/altdesktop/python-dbus-next")
+ (synopsis "Zero-dependency DBus library for Python with asyncio support")
+ (description
+ "This DBus library for Python aims to be a fully-featured high-level
+library primarily geared towards integration of applications into desktop and
+mobile environments.")
+ (license license:expat)))
+
(define-public python-notify2
(package
(name "python-notify2")