summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Enge <andreas@enge.fr>2015-02-14 19:57:23 +0100
committerAndreas Enge <andreas@enge.fr>2015-02-14 19:57:23 +0100
commit0b0e11a9d8c366ebb345eb59209a7fbf5a1db397 (patch)
tree07ea4a38bddf7eaaa99aaaf99e36ec3be06b8e10
parent880ff77c17918b9cf3cb0432e70a8391b9942ec2 (diff)
downloadguix-patches-0b0e11a9d8c366ebb345eb59209a7fbf5a1db397.tar
guix-patches-0b0e11a9d8c366ebb345eb59209a7fbf5a1db397.tar.gz
gnu: Add xdg-utils.
* gnu/packages/freedesktop.scm: New file. * gnu-system.am (GNU_SYSTEM_MODULES): Add it.
-rw-r--r--gnu-system.am1
-rw-r--r--gnu/packages/freedesktop.scm46
2 files changed, 47 insertions, 0 deletions
diff --git a/gnu-system.am b/gnu-system.am
index b2ddbf5972..04e93452ba 100644
--- a/gnu-system.am
+++ b/gnu-system.am
@@ -98,6 +98,7 @@ GNU_SYSTEM_MODULES = \
gnu/packages/fltk.scm \
gnu/packages/fonts.scm \
gnu/packages/fontutils.scm \
+ gnu/packages/freedesktop.scm \
gnu/packages/freeipmi.scm \
gnu/packages/ftp.scm \
gnu/packages/fribidi.scm \
diff --git a/gnu/packages/freedesktop.scm b/gnu/packages/freedesktop.scm
new file mode 100644
index 0000000000..0ee639d20a
--- /dev/null
+++ b/gnu/packages/freedesktop.scm
@@ -0,0 +1,46 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2015 Andreas Enge <andreas@enge.fr>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (gnu packages freedesktop)
+ #:use-module ((guix licenses) #:select (expat))
+ #:use-module (guix packages)
+ #:use-module (guix download)
+ #:use-module (guix build-system gnu))
+
+(define-public xdg-utils
+ (package
+ (name "xdg-utils")
+ (version "1.0.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "http://portland.freedesktop.org/download/xdg-utils-"
+ version ".tgz"))
+ (sha256
+ (base32
+ "1b019d3r1379b60p33d6z44kx589xjgga62ijz9vha95dg8vgbi1"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:tests? #f)) ; no check target
+ (home-page "http://portland.freedesktop.org/")
+ (synopsis "Freedesktop.org scripts for desktop integration")
+ (description "The xdg-utils package is a set of simple scripts that
+provide basic desktop integration functions in the framework of the
+freedesktop.org project.")
+ (license expat))) \ No newline at end of file