summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSylvain Beucler <beuc@beuc.net>2014-11-10 23:47:00 +0100
committerLudovic Courtès <ludo@gnu.org>2014-11-11 00:03:24 +0100
commitbb3b71ce8799d848d327ec9a14ed4bb4c6977bca (patch)
tree2e26ec67e87616b7b4b40224c2a807f2f7f3e131
parent9a4d9333e23c101ba55f4a4eca00e4d955ec6079 (diff)
downloadguix-patches-bb3b71ce8799d848d327ec9a14ed4bb4c6977bca.tar
guix-patches-bb3b71ce8799d848d327ec9a14ed4bb4c6977bca.tar.gz
gnu: Add GNU Freedink.
* gnu/packages/games.scm (freedink-engine, freedink-data): New variables. Co-authored-by: Ludovic Courtès <ludo@gnu.org>.
-rw-r--r--gnu/packages/games.scm57
1 files changed, 57 insertions, 0 deletions
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index a1858bc209..89e80c34e8 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -3,6 +3,7 @@
;;; Copyright © 2014 David Thompson <dthompson2@worcester.edu>
;;; Copyright © 2014 Eric Bavier <bavier@member.fsf.org>
;;; Copyright © 2014 Cyrill Schenkel <cyrill.schenkel@gmail.com>
+;;; Copyright © 2014 Sylvain Beucler <beuc@beuc.net>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -42,6 +43,8 @@
#:use-module (gnu packages databases)
#:use-module (gnu packages sdl)
#:use-module (gnu packages texinfo)
+ #:use-module (gnu packages check)
+ #:use-module (gnu packages fontutils)
#:use-module (guix build-system gnu))
(define-public gnubg
@@ -286,6 +289,60 @@ against the computer in a game of chess, either through the default terminal
interface or via an external visual interface such as GNU XBoard.")
(license gpl3+)))
+(define-public freedink-engine
+ (package
+ (name "freedink-engine")
+ (version "108.4")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://gnu/freedink/freedink-" version
+ ".tar.gz"))
+ (sha256
+ (base32
+ "08c51imfjfcydm7h0va09z8qfw5nc837bi2x754ni2z737hb5kw2"))))
+ (build-system gnu-build-system)
+ (arguments `(#:configure-flags '("--disable-embedded-resources")))
+ (native-inputs `(("gettext" ,gnu-gettext)
+ ("pkg-config" ,pkg-config)))
+ (inputs `(("sdl" ,sdl)
+ ("sdl-image" ,sdl-image)
+ ("sdl-mixer" ,sdl-mixer)
+ ("sdl-ttf" ,sdl-ttf)
+ ("sdl-gfx" ,sdl-gfx)
+ ("fontconfig" ,fontconfig)
+ ("check" ,check)))
+ (home-page "http://www.gnu.org/software/freedink/")
+ (synopsis "Twisted adventures of young pig farmer Dink Smallwood")
+ (description
+ "GNU FreeDink is a free and portable re-implementation of the engine
+for the role-playing game Dink Smallwood. It supports not only the original
+game data files but it also supports user-produced game mods or \"D-Mods\".
+To that extent, it also includes a front-end for managing all of your D-Mods.")
+ (license gpl3+)))
+
+(define-public freedink-data
+ (package
+ (name "freedink-data")
+ (version "1.08.20140901")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://gnu/freedink/freedink-data-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "04f1aa8gfz30qkgv7chjz5n1s8v5hbqs01h2113cq1ylm3isd5sp"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:phases (alist-delete 'configure (alist-delete 'check %standard-phases))
+ #:make-flags (list (string-append "PREFIX=" (assoc-ref %outputs "out")))))
+ (home-page "http://www.gnu.org/software/freedink/")
+ (synopsis "Game data for GNU Freedink")
+ (description
+ "This package contains the game data of GNU Freedink.")
+ (license gpl3+)))
+
+;; TODO: Add freedink-dfarc when there's a wxWidgets package.
+
(define-public xboard
(package
(name "xboard")