summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2016-04-10 21:00:42 +0300
committerEfraim Flashner <efraim@flashner.co.il>2016-04-10 21:00:42 +0300
commit545f4a1c3cb6a613bbeb17faeebbecaa559231fd (patch)
tree1c818fb6ca172c5a06abcabf5cc65143d76ea43e
parenteb3d3503f34b75efdfcb1db6d550921c1a2521d4 (diff)
downloadguix-patches-545f4a1c3cb6a613bbeb17faeebbecaa559231fd.tar
guix-patches-545f4a1c3cb6a613bbeb17faeebbecaa559231fd.tar.gz
gnu: python-pytest-cov: Update to 2.2.1.
* gnu/packages/python.scm (python-pytest-cov): Update to 2.2.1. [native-inputs]: Remove python-setuptools. Move python-coverage, python-pytest ... [inputs]: ... to here. [properties]: Define python2-pytest-cov. (python-pytest-cov): Build with 'strip-python2-variant'. [inputs]: Add python2-setuptools.
-rw-r--r--gnu/packages/python.scm19
1 files changed, 11 insertions, 8 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index e98c594803..2cde276b37 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -1562,30 +1562,33 @@ and many external plugins.")
(define-public python-pytest-cov
(package
(name "python-pytest-cov")
- (version "2.2.0")
+ (version "2.2.1")
(source
(origin
(method url-fetch)
(uri (pypi-uri "pytest-cov" version))
(sha256
- (base32
- "1lf9jsmhqk5nc4w3kzwglmdzjvmi7ajvrsnwv826j3bn0wzx8c92"))))
+ (base32
+ "1yl4nbhzfgsxqlsyk4clafgp9x11zvgrkprm9i2p3fgkwx9jxcm8"))))
(build-system python-build-system)
- (propagated-inputs
+ (inputs
`(("python-coverage" ,python-coverage)
("python-pytest" ,python-pytest)))
- (native-inputs
- `(("python-setuptools" ,python-setuptools)))
(home-page "https://github.com/pytest-dev/pytest-cov")
(synopsis "Pytest plugin for measuring coverage")
(description
"Pytest-cov produces coverage reports. It supports centralised testing and
distributed testing in both @code{load} and @code{each} modes. It also
supports coverage of subprocesses.")
- (license license:expat)))
+ (license license:expat)
+ (properties `((python2-variant . ,(delay python2-pytest-cov))))))
(define-public python2-pytest-cov
- (package-with-python2 python-pytest-cov))
+ (let ((base (package-with-python2 (strip-python2-variant python-pytest-cov))))
+ (package
+ (inherit base)
+ (inputs `(("python2-setuptools" ,python2-setuptools)
+ ,@(package-inputs base))))))
(define-public python-pytest-runner
(package