summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAttila Lendvai <attila@lendvai.name>2022-01-19 09:39:57 +0100
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2022-01-28 01:10:48 +0100
commit3532c7f702f6e5033ddd0c856fc62c0505edaf49 (patch)
tree8930da86268983d5fcdd0aefeaa3c7fbfc75efe6
parent48b988b195e631d56e304ec4449a17279bc062a9 (diff)
downloadguix-patches-3532c7f702f6e5033ddd0c856fc62c0505edaf49.tar
guix-patches-3532c7f702f6e5033ddd0c856fc62c0505edaf49.tar.gz
gnu: Add rust-ethereum-types-0.9, rust-ethereum-types-0.12.
* gnu/packages/crates-io.scm (rust-ethereum-types-0.9): New variable. (rust-ethereum-types-0.12): New variable. Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
-rw-r--r--gnu/packages/crates-io.scm37
1 files changed, 37 insertions, 0 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index f967dbdc87..14d318d3be 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -20080,6 +20080,43 @@ decoding.")
(("rust-serde" ,rust-serde-1)
("rust-serde-json" ,rust-serde-json-1))))))
+(define-public rust-ethereum-types-0.12
+ (package
+ (name "rust-ethereum-types")
+ (version "0.12.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "ethereum-types" version))
+ (file-name
+ (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1bxxacsmb9majw7vd4sndv4dhw3g9srhf7flwq39yy7yaxq6y4q5"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:skip-build? #t))
+ (home-page "https://github.com/paritytech/parity-common")
+ (synopsis "Rust crate exporting some Ethereum types")
+ (description "This crate exports Rust types for values in the Ethereum
+ecosystem.")
+ (license (list license:expat license:asl2.0))))
+
+(define-public rust-ethereum-types-0.9
+ (package
+ (inherit rust-ethereum-types-0.12)
+ (name "rust-ethereum-types")
+ (version "0.9.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "ethereum-types" version))
+ (file-name
+ (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1c1l2sg6li301izl4nzkkfrpc8snafxwnr81vfwygn3bd3zyqfj7"))))))
+
(define-public rust-event-listener-2
(package
(name "rust-event-listener")