summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAttila Lendvai <attila@lendvai.name>2022-01-19 15:59:23 +0100
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2022-01-28 01:10:53 +0100
commitb68c1814f2601833e98847074e6f714af48aacd6 (patch)
tree14bfb9e051c7d6b9e07b85cfcb15b4e5abafb1ee
parent71f5af0c72d4cab5b7cf1c438ae0be43044e3f49 (diff)
downloadguix-patches-b68c1814f2601833e98847074e6f714af48aacd6.tar
guix-patches-b68c1814f2601833e98847074e6f714af48aacd6.tar.gz
gnu: rust-zeroize-1: Update to 1.5.0.
* gnu/packages/crates-io.scm (rust-zeroize-1): Update to 1.5.0. (rust-zeroize-derive-1): Update to 1.3.1. (rust-rsa-0.5): Enable build, and make sure it builds with rust-zeroize 1.5.0 by relaxing the dependency specification. * gnu/packages/rust-apps.scm (rbw): Relax the dependency specification for rust-zeroize. Also reword the description. Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
-rw-r--r--gnu/packages/crates-io.scm29
-rw-r--r--gnu/packages/rust-apps.scm14
2 files changed, 32 insertions, 11 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 3300e8ae3f..d0f61f5329 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -48212,8 +48212,7 @@ wildcard segments")
(base32 "039676a4mj0875phdi7vc0bd37hv84dh0dql6fmk8dl2w81jcp70"))))
(build-system cargo-build-system)
(arguments
- `(#:skip-build? #t
- #:cargo-inputs
+ `(#:cargo-inputs
(("rust-byteorder" ,rust-byteorder-1)
("rust-digest" ,rust-digest-0.9)
("rust-lazy-static" ,rust-lazy-static-1)
@@ -48226,7 +48225,23 @@ wildcard segments")
("rust-rand" ,rust-rand-0.8)
("rust-serde" ,rust-serde-1)
("rust-subtle" ,rust-subtle-2)
- ("rust-zeroize" ,rust-zeroize-1))))
+ ("rust-zeroize" ,rust-zeroize-1))
+ #:cargo-development-inputs
+ (("rust-base64" ,rust-base64-0.13)
+ ("rust-hex" ,rust-hex-0.4)
+ ("rust-hex-literal" ,rust-hex-literal-0.3)
+ ("rust-rand-xorshift" ,rust-rand-xorshift-0.3)
+ ("rust-serde-test" ,rust-serde-test-1)
+ ("rust-sha-1" ,rust-sha-1-0.9)
+ ("rust-sha2" ,rust-sha2-0.9)
+ ("rust-sha3" ,rust-sha3-0.9))
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'configure 'relax-requirements
+ (lambda _
+ (substitute*
+ "Cargo.toml"
+ (("version = \">=1, <1.5\"") "version = \"^1\"")))))))
(home-page "https://github.com/RustCrypto/RSA")
(synopsis "Pure Rust RSA implementation")
(description "This package provides a pure Rust RSA implementation.")
@@ -69824,7 +69839,7 @@ crate.")
(define-public rust-zeroize-1
(package
(name "rust-zeroize")
- (version "1.4.3")
+ (version "1.5.0")
(source
(origin
(method url-fetch)
@@ -69832,7 +69847,7 @@ crate.")
(file-name
(string-append name "-" version ".tar.gz"))
(sha256
- (base32 "068nvl3n5hk6lfn5y24grf2c7anzzqfzjjccscq3md7rqp79v3fn"))))
+ (base32 "1nq8zq5h7ad6kahdk0fxw4fdm0ibycj061jngxqkqchw67n2l8nc"))))
(build-system cargo-build-system)
(arguments
`(#:cargo-inputs
@@ -69849,7 +69864,7 @@ implementation that works everywhere, even WASM!")
(define-public rust-zeroize-derive-1
(package
(name "rust-zeroize-derive")
- (version "1.0.0")
+ (version "1.3.1")
(source
(origin
(method url-fetch)
@@ -69857,7 +69872,7 @@ implementation that works everywhere, even WASM!")
(file-name
(string-append name "-" version ".tar.gz"))
(sha256
- (base32 "18lc9xq9dwvmv81y3bqnw20974nbrs7d20rljb1inz7wd7n1w9fy"))))
+ (base32 "1nzdqyryjnqcrqz0vhddpkd8sybhn0bd8rbd6l33rdhhxwzz3s41"))))
(build-system cargo-build-system)
(arguments
`(#:cargo-inputs
diff --git a/gnu/packages/rust-apps.scm b/gnu/packages/rust-apps.scm
index d2cc949667..a97fcc7968 100644
--- a/gnu/packages/rust-apps.scm
+++ b/gnu/packages/rust-apps.scm
@@ -1307,7 +1307,13 @@ runs a command whenever it detects modifications.")
(lambda _
(substitute*
"guix-vendor/rust-password-hash-0.3.2.tar.gz/Cargo.toml"
- (("version = \">=1, <1.1.0\"") "version = \">=1\"")))))
+ (("version = \">=1, <1.1.0\"") "version = \">=1\""))
+ (substitute*
+ "guix-vendor/rust-rsa-0.5.0.tar.gz/Cargo.toml"
+ (("version = \">=1, <1.5\"") "version = \"^1\""))
+ (substitute*
+ "Cargo.toml"
+ (("version = \"1.4\"") "version = \"^1\"")))))
#:cargo-inputs
(("rust-aes" ,rust-aes-0.7)
("rust-anyhow" ,rust-anyhow-1)
@@ -1352,9 +1358,9 @@ runs a command whenever it detects modifications.")
(home-page "https://git.tozt.net/rbw")
(synopsis "Unofficial Bitwarden CLI")
(description "This package is an unofficial command line client for
-Bitwarden. Although it does come with its own command line client, this client
-is limited by being stateless, which makes it very difficult to use. This
-client avoids this problem by maintaining a background process which is able
+Bitwarden. Although Bitwarden ships with a command line client, but
+it's limited by being stateless, which makes it very difficult to use. This
+client avoids that problem by maintaining a background process which is able
to hold the keys in memory, similar to the way that ssh-agent or gpg-agent
work. This allows the client to be used in a much simpler way, with the
background agent taking care of maintaining the necessary state.")