summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2014-02-21 23:44:52 +0100
committerLudovic Courtès <ludo@gnu.org>2014-02-21 23:49:53 +0100
commit93cc13aabbbac3341a06a27bb8016d94622350cd (patch)
tree1014a6a0fd234c8a83b083de2de8a7b708df34e8
parent9b5b5c17409ce0174d171903f03c1d53dfb455c5 (diff)
downloadguix-patches-93cc13aabbbac3341a06a27bb8016d94622350cd.tar
guix-patches-93cc13aabbbac3341a06a27bb8016d94622350cd.tar.gz
gnu: Add libwebsockets.
* gnu/packages/libwebsockets.scm: New file. * gnu-system.am (GNU_SYSTEM_MODULES): Add it.
-rw-r--r--gnu-system.am1
-rw-r--r--gnu/packages/libwebsockets.scm83
2 files changed, 84 insertions, 0 deletions
diff --git a/gnu-system.am b/gnu-system.am
index e7c7bb2141..d63a80f62a 100644
--- a/gnu-system.am
+++ b/gnu-system.am
@@ -132,6 +132,7 @@ GNU_SYSTEM_MODULES = \
gnu/packages/libunistring.scm \
gnu/packages/libusb.scm \
gnu/packages/libunwind.scm \
+ gnu/packages/libwebsockets.scm \
gnu/packages/lightning.scm \
gnu/packages/linux.scm \
gnu/packages/lout.scm \
diff --git a/gnu/packages/libwebsockets.scm b/gnu/packages/libwebsockets.scm
new file mode 100644
index 0000000000..3f900aef72
--- /dev/null
+++ b/gnu/packages/libwebsockets.scm
@@ -0,0 +1,83 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2014 Ludovic Courtès <ludo@gnu.org>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (gnu packages libwebsockets)
+ #:use-module (guix packages)
+ #:use-module (guix git-download)
+ #:use-module (guix build-system gnu)
+ #:use-module ((guix licenses)
+ #:select (lgpl2.1))
+ #:use-module (gnu packages autotools)
+ #:use-module ((gnu packages compression) #:select (zlib))
+ #:use-module (gnu packages perl)
+ #:use-module (gnu packages openssl))
+
+(define-public libwebsockets
+ (package
+ (name "libwebsockets")
+ (version "1.2")
+ (source (origin
+ ;; The project does not publish tarballs, so we have to take
+ ;; things from Git.
+ (method git-fetch)
+ (uri (git-reference
+ (url "git://git.libwebsockets.org/libwebsockets")
+ (commit (string-append "v" version
+ "-chrome26-firefox18"))))
+ (sha256
+ (base32
+ "1293hbz8qj4p27m1qjf8dn97r10xjyiwdpq491m87zi025s558cl"))
+ (file-name (string-append name "-" version))))
+
+ ;; The package has both CMake and GNU build systems, but the latter is
+ ;; apparently better supported (CMake-generated makefiles lack an
+ ;; 'install' target, for instance.)
+ (build-system gnu-build-system)
+
+ (arguments
+ '(#:phases (alist-replace
+ 'unpack
+ ;; FIXME: Remove this when gnu-build-system handles that
+ ;; case correctly.
+ (lambda* (#:key source #:allow-other-keys)
+ (mkdir "source")
+ (chdir "source")
+ (copy-recursively source ".")
+ #t)
+
+ (alist-cons-before
+ 'configure 'bootstrap
+ (lambda _
+ (chmod "libwebsockets-api-doc.html" #o666)
+ (zero? (system* "./autogen.sh")))
+ %standard-phases))))
+ (native-inputs `(("autoconf" ,autoconf)
+ ("automake" ,automake)
+ ("libtool" ,libtool "bin")
+ ("perl" ,perl))) ; to build the HTML doc
+ (inputs `(("zlib" ,zlib)
+ ("openssl" ,openssl)))
+ (synopsis "WebSockets library written in C")
+ (description
+ "libwebsockets is a library that allows C programs to establish client
+and server WebSockets connections---a protocol layered above HTTP that allows
+for efficient socket-like bidirectional reliable communication channels.")
+ (home-page "http://libwebsockets.org/")
+
+ ;; This is LGPLv2.1-only with extra exceptions specified in 'LICENSE'.
+ (license lgpl2.1)))