summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAttila Lendvai <attila@lendvai.name>2022-01-19 14:51:42 +0100
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2022-01-28 01:10:51 +0100
commit213f2cc27b8a7498af5fccffd7d59205e16811f9 (patch)
tree422c1c5881831b5014c1d7e94e72b3d523d59bb3
parent2588ee6b28ed018472d64b9a350b38d858503d03 (diff)
downloadguix-patches-213f2cc27b8a7498af5fccffd7d59205e16811f9.tar
guix-patches-213f2cc27b8a7498af5fccffd7d59205e16811f9.tar.gz
gnu: Add rust-core2-0.3.
* gnu/packages/crates-io.scm (rust-core2-0.3): New variable. Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
-rw-r--r--gnu/packages/crates-io.scm20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 5d598c82f2..9b2e149c39 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -12845,6 +12845,26 @@ numbers using the CORDIC method.")
management. It supports signed and private (encrypted, authenticated) jars.")
(license (list license:expat license:asl2.0))))
+(define-public rust-core2-0.3
+ (package
+ (name "rust-core2")
+ (version "0.3.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "core2" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32 "1wzzy5iazdk5caadxvjfwrd312rbg7a55a1zpmsdrhk3kfpa77r3"))))
+ (build-system cargo-build-system)
+ (arguments `(#:cargo-inputs (("rust-memchr" ,rust-memchr-2))))
+ (home-page "https://github.com/bbqsrc/core2")
+ (synopsis "Bare essentials of @code{std::io} for use in @code{no_std}")
+ (description
+ "This package provides the bare essentials of @code{std::io} for use
+in @code{no_std}. Alloc support is optional.")
+ (license (list license:asl2.0 license:expat))))
+
(define-public rust-cookie-0.14
(package
(inherit rust-cookie-0.15)