summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2021-08-01 11:24:22 +0300
committerEfraim Flashner <efraim@flashner.co.il>2022-01-27 16:14:07 +0200
commit89022186256d7d0478b3e99ab664e507c6f0454b (patch)
tree223952db3043509f582d1c05a6b907c960bcac8c
parente778910bdfc68c60a5be59aac93049d32feae904 (diff)
downloadguix-patches-89022186256d7d0478b3e99ab664e507c6f0454b.tar
guix-patches-89022186256d7d0478b3e99ab664e507c6f0454b.tar.gz
gnu: pcre: Fix building on riscv64-linux.
* gnu/packages/pcre.scm (pcre)[arguments]: Adjust configure-flags to not build with JIT when building for riscv64-linux.
-rw-r--r--gnu/packages/pcre.scm5
1 files changed, 4 insertions, 1 deletions
diff --git a/gnu/packages/pcre.scm b/gnu/packages/pcre.scm
index 0324a21261..cf8c1fb2b0 100644
--- a/gnu/packages/pcre.scm
+++ b/gnu/packages/pcre.scm
@@ -33,6 +33,7 @@
#:use-module (guix utils)
#:use-module (guix packages)
#:use-module (guix download)
+ #:use-module (guix utils)
#:use-module (guix build-system gnu))
(define-public pcre
@@ -62,7 +63,9 @@
"--enable-pcre16"
"--enable-pcre32"
;; pcretest fails on powerpc32.
- ,@(if (target-ppc32?)
+ ;; riscv64-linux is an unsupported architecture.
+ ,@(if (or (target-ppc32?)
+ (target-riscv64?))
'()
`("--enable-jit")))
#:phases (modify-phases %standard-phases