summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuillaume Le Vaillant <glv@posteo.net>2022-01-27 14:34:35 +0100
committerGuillaume Le Vaillant <glv@posteo.net>2022-01-27 16:31:21 +0100
commit8696b2a09f96ef58e14ddc1053f5e7cc361cd8e2 (patch)
tree1c94a1a09e1968a20b6cc00ff485da742ffeb1c1
parentc469a8b09e6cb54d0d7e76f1baac9591c9dc958b (diff)
downloadguix-patches-8696b2a09f96ef58e14ddc1053f5e7cc361cd8e2.tar
guix-patches-8696b2a09f96ef58e14ddc1053f5e7cc361cd8e2.tar.gz
gnu: soapyhackrf: Update to 0.3.4.
* gnu/packages/radio.scm (soapyhackrf): Update to 0.3.4.
-rw-r--r--gnu/packages/radio.scm48
1 files changed, 22 insertions, 26 deletions
diff --git a/gnu/packages/radio.scm b/gnu/packages/radio.scm
index 7a94113e18..1705fdfdac 100644
--- a/gnu/packages/radio.scm
+++ b/gnu/packages/radio.scm
@@ -320,32 +320,28 @@ SoapySDR library.")
(license license:expat)))
(define-public soapyhackrf
- ;; Use commit because some fixes are not in a release yet
- ;; (last release was in 2018).
- (let ((commit "8d2e7beebb4c451609cb0cee236fa4d20a0e28b1")
- (revision "2"))
- (package
- (name "soapyhackrf")
- (version (git-version "0.3.3" revision commit))
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/pothosware/SoapyHackRF")
- (commit commit)))
- (file-name (git-file-name name version))
- (sha256
- (base32 "0l5890a240i1fan88jjdxaqswk3as410nlrv12a698fy9npqh4w4"))))
- (build-system cmake-build-system)
- (inputs
- (list hackrf soapysdr))
- (arguments
- `(#:tests? #f)) ; No test suite
- (home-page "https://github.com/pothosware/SoapyHackRF/wiki")
- (synopsis "SoapySDR HackRF module")
- (description
- "This package provides HackRF devices support to the SoapySDR library.")
- (license license:expat))))
+ (package
+ (name "soapyhackrf")
+ (version "0.3.4")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/pothosware/SoapyHackRF")
+ (commit (string-append "soapy-hackrf-" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0wnnsm3c4ivwcbs1b68svbyds13aajws9mqk2xjc2pqgj0fdhcvz"))))
+ (build-system cmake-build-system)
+ (inputs
+ (list hackrf soapysdr))
+ (arguments
+ `(#:tests? #f)) ; No test suite
+ (home-page "https://github.com/pothosware/SoapyHackRF/wiki")
+ (synopsis "SoapySDR HackRF module")
+ (description
+ "This package provides HackRF devices support to the SoapySDR library.")
+ (license license:expat)))
(define-public soapyrtlsdr
(package