summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOleg Pykhalov <go.wigust@gmail.com>2020-08-29 00:14:09 +0300
committerOleg Pykhalov <go.wigust@gmail.com>2020-08-29 00:15:54 +0300
commit1922811e0e586efaa5c76ce5e0094814bbad1f76 (patch)
tree2ff4dab35ac9aeaeec16394ecbf50b739ba4934a
parentcb3bb849f2d0409313db8ed9e253e5cae7f2fc95 (diff)
downloadguix-patches-1922811e0e586efaa5c76ce5e0094814bbad1f76.tar
guix-patches-1922811e0e586efaa5c76ce5e0094814bbad1f76.tar.gz
gnu: emacs-git-auto-commit-mode: Update to 4.7.0.
* gnu/packages/emacs-xyz.scm (emacs-git-auto-commit-mode): Update to 4.7.0.
-rw-r--r--gnu/packages/emacs-xyz.scm52
1 files changed, 25 insertions, 27 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 8015fa5f7e..0755926ffe 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -16553,35 +16553,33 @@ scroll up to read the function name and then scroll down to original position.")
(license license:gpl3+))))
(define-public emacs-git-auto-commit-mode
- (let ((commit "23abaff792c0459e51e596d3fecd5513617e8cb1")
- (revision "1"))
- (package
- (name "emacs-git-auto-commit-mode")
- (version (git-version "4.6.0" revision commit))
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/ryuslash/git-auto-commit-mode")
- (commit commit)))
- (file-name (git-file-name name version))
- (sha256
- (base32 "0hqj34q8z4jg86zz2lwfvj6xk07b4g1222h9y1zqs83qgivwpk1l"))))
- (build-system emacs-build-system)
- (native-inputs
- `(("emacs-buttercup" ,emacs-buttercup)
- ("git" ,git)))
- (arguments
- `(#:tests? #t
- #:test-command '("buttercup" "-L" ".")))
- (home-page "https://github.com/ryuslash/git-auto-commit-mode")
- (synopsis "Emacs Minor mode to automatically commit and push")
- (description "@code{git-auto-commit-mode} is an Emacs minor mode that
+ (package
+ (name "emacs-git-auto-commit-mode")
+ (version "4.7.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/ryuslash/git-auto-commit-mode")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0gpib57f7xza04g3iyihw5v15hb7pncqsmvyggib902yvcxlkvqf"))))
+ (build-system emacs-build-system)
+ (native-inputs
+ `(("emacs-buttercup" ,emacs-buttercup)
+ ("git" ,git)))
+ (arguments
+ `(#:tests? #t
+ #:test-command '("buttercup" "-L" ".")))
+ (home-page "https://github.com/ryuslash/git-auto-commit-mode")
+ (synopsis "Emacs Minor mode to automatically commit and push")
+ (description "@code{git-auto-commit-mode} is an Emacs minor mode that
tries to commit changes to a file after every save.
-When @code{gac-automatically-push-p} is non-nil, it also tries to push to
-the current upstream.")
- (license license:gpl3+))))
+When @code{gac-automatically-push-p} is non-nil, it also tries to push to the
+current upstream.")
+ (license license:gpl3+)))
(define-public emacs-scroll-on-drag
(let ((commit "888abd04c34753b1fc4b2fe541bc004ebec5c996")