summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2022-01-18 15:33:39 +0200
committerEfraim Flashner <efraim@flashner.co.il>2022-01-26 16:15:40 +0200
commitc5908b5c8093265e720e825f39ed3e5f69ade723 (patch)
tree0c38e778269f63539bae28590d6143b252941fd3
parent3d8ee86ace82f37ebbfea0e303468284538ba52f (diff)
downloadguix-patches-c5908b5c8093265e720e825f39ed3e5f69ade723.tar
guix-patches-c5908b5c8093265e720e825f39ed3e5f69ade723.tar.gz
gnu: Add go-github-com-bradfitz-gomemcache.
* gnu/packages/databases.scm (go-github-com-bradfitz-gomemcache): New variable.
-rw-r--r--gnu/packages/databases.scm32
1 files changed, 31 insertions, 1 deletions
diff --git a/gnu/packages/databases.scm b/gnu/packages/databases.scm
index 064d8c77e0..ab9180bbc4 100644
--- a/gnu/packages/databases.scm
+++ b/gnu/packages/databases.scm
@@ -10,7 +10,7 @@
;;; Copyright © 2015 Eric Dvorsak <eric@dvorsak.fr>
;;; Copyright © 2016 Hartmut Goebel <h.goebel@crazy-compilers.com>
;;; Copyright © 2016 Christine Lemmer-Webber <cwebber@dustycloud.org>
-;;; Copyright © 2015, 2016, 2017, 2018, 2019, 2020, 2021 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2015, 2016, 2017, 2018, 2019, 2020, 2021, 2022 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2016, 2017 Nikita <nikita@n0.is>
;;; Copyright © 2016, 2017, 2018 Roel Janssen <roel@gnu.org>
;;; Copyright © 2016 David Craven <david@craven.ch>
@@ -632,6 +632,36 @@ around TangentOrg’s libmemcached library, and can be used as a drop-in
replacement for the code@{python-memcached} library.")
(license license:bsd-3)))
+(define-public go-github-com-bradfitz-gomemcache
+ (package
+ (name "go-github-com-bradfitz-gomemcache")
+ (version "0.0.0-20190913173617-a41fca850d0b")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/bradfitz/gomemcache")
+ (commit (go-version->git-ref version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "18qpds6xr73jy80pj7l3pc1l1ndcy3va2dl8fzk17bgwg49sxwfz"))
+ (modules '((guix build utils)))
+ (snippet
+ '(begin
+ ;; Fixes the 'untyped-int -> string of one rune' issue.
+ ;; https://github.com/golang/go/issues/32479
+ (substitute* "memcache/memcache_test.go"
+ (("string\\(0x7f") "string(rune(0x7f)"))))))
+ (build-system go-build-system)
+ (arguments
+ '(#:unpack-path "github.com/bradfitz/gomemcache"
+ #:import-path "github.com/bradfitz/gomemcache/memcache"))
+ (home-page "https://github.com/bradfitz/gomemcache")
+ (synopsis "Memcache client library in Go")
+ (description
+ "This is a memcache client library for the Go programming language.")
+ (license license:asl2.0)))
+
(define-public litecli
(package
(name "litecli")