summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVinicius Monego <monego@posteo.net>2022-01-09 04:37:22 +0000
committerLudovic Courtès <ludo@gnu.org>2022-01-25 23:54:44 +0100
commitb28be250702a9b87538a8503dc4f0792989d8d81 (patch)
tree31965bc29bb25675adcc74dbf1dfab31254af2ad
parent5543f80df75be94b5f9e1511a07c6feab6f59ba1 (diff)
downloadguix-patches-b28be250702a9b87538a8503dc4f0792989d8d81.tar
guix-patches-b28be250702a9b87538a8503dc4f0792989d8d81.tar.gz
gnu: Add python-pyvo.
* gnu/packages/astronomy.scm (python-pyvo): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/astronomy.scm37
1 files changed, 36 insertions, 1 deletions
diff --git a/gnu/packages/astronomy.scm b/gnu/packages/astronomy.scm
index a7a07fa3a8..ef85ec79e0 100644
--- a/gnu/packages/astronomy.scm
+++ b/gnu/packages/astronomy.scm
@@ -6,7 +6,7 @@
;;; Copyright © 2020 R Veera Kumar <vkor@vkten.in>
;;; Copyright © 2020, 2021 Guillaume Le Vaillant <glv@posteo.net>
;;; Copyright © 2021 Sharlatan Hellseher <sharlatanus@gmail.com>
-;;; Copyright © 2021 Vinicius Monego <monego@posteo.net>
+;;; Copyright © 2021, 2022 Vinicius Monego <monego@posteo.net>
;;; Copyright © 2021 Greg Hogan <code@greghogan.com>
;;; Copyright © 2021 Foo Chuan Wei <chuanwei.foo@hotmail.com>
;;;
@@ -55,6 +55,7 @@
#:use-module (gnu packages python-check)
#:use-module (gnu packages python-crypto)
#:use-module (gnu packages python-science)
+ #:use-module (gnu packages python-web)
#:use-module (gnu packages python-xyz)
#:use-module (gnu packages qt)
#:use-module (gnu packages time)
@@ -705,6 +706,40 @@ much of the core functionality and some common tools needed for performing
astronomy and astrophysics.")
(license license:bsd-3)))
+(define-public python-pyvo
+ (package
+ (name "python-pyvo")
+ (version "1.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "pyvo" version))
+ (sha256
+ (base32 "1lap703wxbyxqlbk85myirp4pkdnc6cg10xhfajfsvz5k0hm5ffw"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (replace 'check
+ (lambda* (#:key inputs outputs tests? #:allow-other-keys)
+ (when tests?
+ (add-installed-pythonpath inputs outputs)
+ (invoke "python" "-m" "pytest" "--pyargs" "pyvo" "-k"
+ (string-append ; these tests use the network
+ "not test_access_with_string"
+ " and not test_access_with_list"
+ " and not test_access_with_expansion"))))))))
+ (native-inputs
+ (list python-pytest-astropy python-requests-mock))
+ (propagated-inputs
+ (list python-astropy python-mimeparse python-pillow python-requests))
+ (home-page "https://github.com/astropy/pyvo")
+ (synopsis "Access Virtual Observatory data and services")
+ (description
+ "PyVO is a package providing access to remote data and services of the
+Virtual observatory (VO) using Python.")
+ (license license:bsd-3)))
+
(define-public python-astral
(package
(name "python-astral")