summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2022-01-18 15:51:44 +0200
committerEfraim Flashner <efraim@flashner.co.il>2022-01-26 16:15:45 +0200
commit87c4a15da02abb9feb7d4d8cef80ff2bf20454f1 (patch)
treeebc9ca80f01e645690a1c198d6cd829b810ad7d4
parent0045abb5bb369d302e1f9eed26dc556936bae9c5 (diff)
downloadguix-patches-87c4a15da02abb9feb7d4d8cef80ff2bf20454f1.tar
guix-patches-87c4a15da02abb9feb7d4d8cef80ff2bf20454f1.tar.gz
gnu: Add go-github-com-cupcake-rdb.
* gnu/packages/databases.scm (go-github-com-cupcake-rdb): New variable.
-rw-r--r--gnu/packages/databases.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/databases.scm b/gnu/packages/databases.scm
index 49840c23fd..9bc15e71b2 100644
--- a/gnu/packages/databases.scm
+++ b/gnu/packages/databases.scm
@@ -2377,6 +2377,29 @@ one-to-one, while still providing an idiomatic interface.")
(home-page "https://github.com/redis/redis-rb")
(license license:expat)))
+(define-public go-github-com-cupcake-rdb
+ (package
+ (name "go-github-com-cupcake-rdb")
+ (version "0.0.0-20161107195141-43ba34106c76")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/tent/rdb")
+ (commit (go-version->git-ref version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1l4bsn5yj8r875crz1rsk6dlvhv0bd8mgazsch5vl4c19v0fs2ib"))))
+ (build-system go-build-system)
+ (arguments '(#:import-path "github.com/cupcake/rdb"))
+ (native-inputs
+ (list go-gopkg-in-check-v1))
+ (home-page "https://github.com/tent/rdb")
+ (synopsis "Redis RDB parser for Go")
+ (description
+ "Package rdb implements parsing and encoding of the Redis RDB file format.")
+ (license license:expat)))
+
(define-public kyotocabinet
(package
(name "kyotocabinet")