summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVinicius Monego <monego@posteo.net>2022-01-09 04:38:40 +0000
committerLudovic Courtès <ludo@gnu.org>2022-01-25 23:54:45 +0100
commit5e51ccc120871502609de10f21b897af33594a65 (patch)
tree1ac4602969158e719c121b404d332e4e51930d1b
parentfb12d6b48eb527a0d09011bd1f6a7fea1f5d2c49 (diff)
downloadguix-patches-5e51ccc120871502609de10f21b897af33594a65.tar
guix-patches-5e51ccc120871502609de10f21b897af33594a65.tar.gz
gnu: Add python-photutils.
* gnu/packages/astronomy.scm (python-photutils): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/astronomy.scm34
1 files changed, 34 insertions, 0 deletions
diff --git a/gnu/packages/astronomy.scm b/gnu/packages/astronomy.scm
index 1573003c7e..20961e1436 100644
--- a/gnu/packages/astronomy.scm
+++ b/gnu/packages/astronomy.scm
@@ -789,6 +789,40 @@ astronomy and astrophysics.")
to access online Astronomical data. Each web service has its own sub-package.")
(license license:bsd-3)))
+(define-public python-photutils
+ (package
+ (name "python-photutils")
+ (version "1.3.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "photutils" version))
+ (sha256
+ (base32 "1a8djakaya6w5iv9237gkcz39brqzgrfs2wqrl0izi1s85cfdymn"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:test-target "pytest"
+ #:phases
+ (modify-phases %standard-phases
+ ;; This file is opened in both install and check phases.
+ (add-before 'install 'writable-compiler
+ (lambda _ (make-file-writable "photutils/_compiler.c")))
+ (add-before 'check 'writable-compiler
+ (lambda _ (make-file-writable "photutils/_compiler.c"))))))
+ (propagated-inputs
+ (list python-astropy python-numpy))
+ (native-inputs
+ (list python-cython
+ python-extension-helpers
+ python-pytest-astropy
+ python-pytest-runner
+ python-setuptools-scm))
+ (home-page "https://github.com/astropy/photutils")
+ (synopsis "Source detection and photometry")
+ (description "Photutils is an Astropy package for detection and photometry
+of astronomical sources.")
+ (license license:bsd-3)))
+
(define-public python-pyvo
(package
(name "python-pyvo")