summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2022-01-26 08:37:14 +0100
committerRicardo Wurmus <rekado@elephly.net>2022-01-26 08:37:57 +0100
commit3563558172e2f2711334bdf5ad5ce35c1452923a (patch)
treeef3bffacf843574dae9183d67ff7f69e0982ac24
parent011db003ce43bf5dca41e5512ba07a42c77cb9ae (diff)
downloadguix-patches-3563558172e2f2711334bdf5ad5ce35c1452923a.tar
guix-patches-3563558172e2f2711334bdf5ad5ce35c1452923a.tar.gz
gnu: nyacc: Fix bug 60474.
* gnu/packages/mes.scm (nyacc)[arguments]: Add build phase 'fix-60474.
-rw-r--r--gnu/packages/mes.scm9
1 files changed, 9 insertions, 0 deletions
diff --git a/gnu/packages/mes.scm b/gnu/packages/mes.scm
index 87c933d9ea..5115374514 100644
--- a/gnu/packages/mes.scm
+++ b/gnu/packages/mes.scm
@@ -112,6 +112,15 @@ extensive examples, including parsers for the Javascript and C99 languages.")
(("GUILE_GLOBAL_SITE=\\$prefix.*")
"GUILE_GLOBAL_SITE=\
$prefix/share/guile/site/$GUILE_EFFECTIVE_VERSION\n")))))
+ (arguments
+ '(#:phases
+ (modify-phases %standard-phases
+ ;; See https://savannah.nongnu.org/bugs/index.php?60474
+ (add-after 'unpack 'fix-60474
+ (lambda _
+ (substitute* "module/nyacc/lang/c99/parser.scm"
+ (("\\(memq \\(car stmt\\) '\\(include include-next\\)\\)")
+ "(memq (car stmt) '(include include-next define))")))))))
(inputs (list guile-3.0))
(description
"@acronym{NYACC, Not Yet Another Compiler Compiler} is set of Guile modules