summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2017-07-29 13:24:56 +0200
committerMarius Bakke <mbakke@fastmail.com>2017-08-22 23:13:42 +0200
commit2e4569829e12afd23bb4671704a6f48c6b29c786 (patch)
treefccdd66fd634dded3985fe5bba75918c244e28cb
parent7ac2cab8c92c614e85764a1b2053365f26e0afac (diff)
downloadguix-patches-2e4569829e12afd23bb4671704a6f48c6b29c786.tar
guix-patches-2e4569829e12afd23bb4671704a6f48c6b29c786.tar.gz
gnu: Add f2fs-tools.
* gnu/packages/linux.scm (f2fs-tools): New variable.
-rw-r--r--gnu/packages/linux.scm36
1 files changed, 36 insertions, 0 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 52637f1332..6c70328eba 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -3219,6 +3219,42 @@ repair and easy administration.")
from the btrfs-progs package. It is meant to be used in initrds.")
(license (package-license btrfs-progs))))
+(define-public f2fs-tools
+ (package
+ (name "f2fs-tools")
+ (version "1.8.0")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://git.kernel.org/cgit/linux/kernel/git/jaegeuk"
+ "/f2fs-tools.git/snapshot/" name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1bir9ladb58ijlcvrjrq1fb1xv5ys50zdjaq0yzliib0apsyrnyl"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'bootstrap
+ (lambda _
+ (zero? (system* "autoreconf" "-vif")))))))
+ (native-inputs
+ `(("autoconf" ,autoconf)
+ ("automake" ,automake)
+ ("libtool" ,libtool)
+ ("pkg-config" ,pkg-config)))
+ (inputs
+ `(("libuuid" ,util-linux)))
+ (home-page "https://f2fs.wiki.kernel.org/")
+ (synopsis "Userland tools for f2fs")
+ (description
+ "F2FS, the Flash-Friendly File System, is a modern file system
+designed to be fast and durable on flash devices such as solid-state
+disks and SD cards. This package provides the userland utilities.")
+ ;; The formatting utility, libf2fs and include/f2fs_fs.h is dual
+ ;; GPL2/LGPL2.1, everything else is GPL2 only. See 'COPYING'.
+ (license (list license:gpl2 license:lgpl2.1))))
+
(define-public freefall
(package
(name "freefall")