summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Danckaert <post@thomasdanckaert.be>2017-02-21 21:33:02 +0100
committerDanny Milosavljevic <dannym@scratchpost.org>2017-03-06 03:24:29 +0100
commit2aa6d3aeeb49f116aab2757b217cd25fab71d7d6 (patch)
treec7a24b29b40debda3fc30ad1533e22395f298e7b
parentec0742133297ac02b684ee1e81d1143de06956f7 (diff)
downloadguix-patches-2aa6d3aeeb49f116aab2757b217cd25fab71d7d6.tar
guix-patches-2aa6d3aeeb49f116aab2757b217cd25fab71d7d6.tar.gz
gnu: Add python-colorspacious.
* gnu/packages/python.scm (python-colorspacious, python2-colorspacious): New variables. Signed-off-by: Danny Milosavljevic <dannym@scratchpost.org>
-rw-r--r--gnu/packages/python.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 0d1dd18a58..181436e399 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -3826,6 +3826,30 @@ To address this and enable easy cycling over arbitrary @code{kwargs}, the
(define-public python2-cycler
(package-with-python2 python-cycler))
+(define-public python-colorspacious
+ (package
+ (name "python-colorspacious")
+ (version "1.1.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/njsmith/colorspacious/archive/v"
+ version ".tar.gz"))
+ (file-name (string-append name "-" version))
+ (sha256
+ (base32 "1vflh5jm32qb0skza2i8pjacv09w6gq84fqpp2nj77s0rbmzgr4k"))))
+ (build-system python-build-system)
+ (propagated-inputs
+ `(("python-numpy" ,python-numpy)))
+ (home-page "https://github.com/njsmith/colorspacious")
+ (synopsis "Python library for colorspace conversions")
+ (description "@code{colorspacious} is a Python library that lets you
+convert between colorspaces like sRGB, XYZ, CIEL*a*b*, CIECAM02, CAM02-UCS, etc.")
+ (license license:expat)))
+
+(define-public python2-colorspacious
+ (package-with-python2 python-colorspacious))
+
(define-public python-matplotlib
(package
(name "python-matplotlib")