summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBird <birdsite@airmail.cc>2022-01-21 04:32:39 +0000
committerLeo Famulari <leo@famulari.name>2022-01-25 13:26:44 -0500
commitcc74d19d663b78a9ec8207d7e3a41cabfbe1a100 (patch)
tree8850ff821a53e249d325b423afdd2d0d8e44a5f1
parenta58bcf927c02f17c5b24fc935393932096127c4a (diff)
downloadguix-patches-cc74d19d663b78a9ec8207d7e3a41cabfbe1a100.tar
guix-patches-cc74d19d663b78a9ec8207d7e3a41cabfbe1a100.tar.gz
gnu: Add gallery-dl.
* gnu/packages/video.scm (gallery-dl): New variable. Signed-off-by: Leo Famulari <leo@famulari.name>
-rw-r--r--gnu/packages/video.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index 1b26418eea..c568c61b85 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -2246,6 +2246,28 @@ possibility to play Youtube videos, download subtitles, remember
the last played position, etc.")
(license license:gpl2+)))
+(define-public gallery-dl
+ (package
+ (name "gallery-dl")
+ (version "1.20.1")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/mikf/gallery-dl"
+ "/releases/download/v" version "/gallery_dl-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "0qkz8aznvybdqrjxsl6ir319ras05mi8l0sal4mgi18l70jndh51"))))
+ (build-system python-build-system)
+ (inputs (list python-requests ffmpeg))
+ (home-page "https://github.com/mikf/gallery-dl")
+ (synopsis "Command-line program to download images from several sites")
+ (description "Command-line program to download image galleries
+and collections from several image hosting sites
+While this package can use youtube-dl or yt-dlp packages to download videos,
+the focus is more on images and image hosting sites.")
+ (license license:gpl2)))
+
(define-public gnome-mpv
(deprecated-package "gnome-mpv" celluloid))