summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen Woodcroft <donttrustben@gmail.com>2016-05-17 21:07:00 +1000
committerBen Woodcroft <donttrustben@gmail.com>2016-05-17 21:07:00 +1000
commit122395f9fc42de7dbe2643b437ca4e484adb8ba0 (patch)
treefe2f22b43e6249cc4e775c518f95ba2fb9705e3d
parenta9e41d2faf979e1b39e2d587b940a89e071804c2 (diff)
downloadguix-patches-122395f9fc42de7dbe2643b437ca4e484adb8ba0.tar
guix-patches-122395f9fc42de7dbe2643b437ca4e484adb8ba0.tar.gz
gnu: diamond: Update to 0.8.1.
* gnu/packages/bioinformatics.scm (diamond): Update to 0.8.1. [source]: Remove 'snippet'. [build-system]: Use cmake-build-system. [arguments]: Remove modifications to phases. [native-inputs]: Remove field. [inputs]: Remove 'boost'.
-rw-r--r--gnu/packages/bioinformatics.scm31
1 files changed, 5 insertions, 26 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index aa16d39861..f882185936 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -1482,7 +1482,7 @@ identify enrichments with functional annotations of the genome.")
(define-public diamond
(package
(name "diamond")
- (version "0.7.9")
+ (version "0.8.1")
(source (origin
(method url-fetch)
(uri (string-append
@@ -1491,33 +1491,12 @@ identify enrichments with functional annotations of the genome.")
(file-name (string-append name "-" version ".tar.gz"))
(sha256
(base32
- "0hfkcfv9f76h5brbyw9fyvmc0l9cmbsxrcdqk0fa9xv82zj47p15"))
- (snippet '(begin
- (delete-file "bin/diamond")
- #t))))
- (build-system gnu-build-system)
+ "1dqancz32c2l7w1b2vkvh5zqa2jnf99j1c41djnx1l8pxn044zdc"))))
+ (build-system cmake-build-system)
(arguments
- '(#:tests? #f ;no "check" target
- #:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'enter-source-dir
- (lambda _
- (chdir "src")
- #t))
- (delete 'configure)
- (replace 'install
- (lambda* (#:key outputs #:allow-other-keys)
- (let ((bin (string-append (assoc-ref outputs "out")
- "/bin")))
- (mkdir-p bin)
- (copy-file "../bin/diamond"
- (string-append bin "/diamond"))
- #t))))))
- (native-inputs
- `(("bc" ,bc)))
+ '(#:tests? #f)) ; no "check" target
(inputs
- `(("boost" ,boost)
- ("zlib" ,zlib)))
+ `(("zlib" ,zlib)))
(home-page "https://github.com/bbuchfink/diamond")
(synopsis "Accelerated BLAST compatible local sequence aligner")
(description