summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2020-12-16 18:59:34 +0100
committerHartmut Goebel <h.goebel@crazy-compilers.com>2021-01-08 10:33:12 +0100
commitfe9ed313ebf25da5013e7d3b5f60b0fb2a7aed31 (patch)
tree88dc3dc0becced5da862a39f19d1fb5451c34584
parent2e4bfeb4fef46a0b74f5228bda67e0740c751dba (diff)
downloadguix-patches-fe9ed313ebf25da5013e7d3b5f60b0fb2a7aed31.tar
guix-patches-fe9ed313ebf25da5013e7d3b5f60b0fb2a7aed31.tar.gz
gnu: Replace rust-win-crypto-ng-0.2 by rust-win-crypto-ng-0.4.
* gnu/packages/crates-io.scm (rust-win-crypto-ng-0.2): Update to 0.4.0 and rename to (rust-win-crypto-ng-0.4). [arguments]{cargo-inouts}: Add rust-cipher.
-rw-r--r--gnu/packages/crates-io.scm9
1 files changed, 5 insertions, 4 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 7a8bd9e600..ee0163b3ad 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -40625,22 +40625,23 @@ color in a Windows console.")
(license (list license:unlicense
license:expat))))
-(define-public rust-win-crypto-ng-0.2
+(define-public rust-win-crypto-ng-0.4
(package
(name "rust-win-crypto-ng")
- (version "0.2.1")
+ (version "0.4.0")
(source
(origin
(method url-fetch)
(uri (crate-uri "win-crypto-ng" version))
(file-name (string-append name "-" version ".tar.gz"))
(sha256
- (base32 "0ab0iwl4bmqvysypyn6xgax7rlh3w524jji2y1zfwfpdr7wwyv23"))))
+ (base32 "0v26ssjip8fdilj1j6csnvcny98gb90ra1qlnm2xwjlgivlr5kr4"))))
(build-system cargo-build-system)
(arguments
`(#:skip-build? #t
#:cargo-inputs
- (("rust-doc-comment" ,rust-doc-comment-0.3)
+ (("rust-cipher" ,rust-cipher-0.2)
+ ("rust-doc-comment" ,rust-doc-comment-0.3)
("rust-rand-core" ,rust-rand-core-0.5)
("rust-winapi" ,rust-winapi-0.3)
("rust-zeroize" ,rust-zeroize-1))))