summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2018-02-26 03:05:58 +0100
committerMarius Bakke <mbakke@fastmail.com>2018-02-26 03:05:58 +0100
commiteddb9dacd2943301c7d1bc3cbad8df6ddab09c5a (patch)
treec9c4060db0e99dfdd57ed7b7fc77cd4c3799beae
parentb8509387d1e303b24204213c09fe82f35899ebff (diff)
downloadguix-patches-eddb9dacd2943301c7d1bc3cbad8df6ddab09c5a.tar
guix-patches-eddb9dacd2943301c7d1bc3cbad8df6ddab09c5a.tar.gz
gnu: behave: Update to 1.2.6.
* gnu/packages/check.scm (behave): Update to 1.2.6. [source](uri): Adjust file extension. [native-inputs]: Add PYTHON-PATHPY and PYTHON-PYTEST.
-rw-r--r--gnu/packages/check.scm10
1 files changed, 6 insertions, 4 deletions
diff --git a/gnu/packages/check.scm b/gnu/packages/check.scm
index 8e1eb127b2..fbd2ac4f80 100644
--- a/gnu/packages/check.scm
+++ b/gnu/packages/check.scm
@@ -1629,18 +1629,20 @@ backported from Python 2.7 for Python 2.4+.")
(define-public behave
(package
(name "behave")
- (version "1.2.5")
+ (version "1.2.6")
(source (origin
(method url-fetch)
- (uri (pypi-uri "behave" version ".tar.bz2"))
+ (uri (pypi-uri "behave" version))
(sha256
(base32
- "1iypp6z46r19n4xmgx6m1lwmlpfjh8vapq8izigrqlaarvp2y64c"))))
+ "11hsz365qglvpp1m1w16239c3kiw15lw7adha49lqaakm8kj6rmr"))))
(build-system python-build-system)
(native-inputs
`(("python-mock" ,python-mock)
("python-nose" ,python-nose)
- ("python-pyhamcrest" ,python-pyhamcrest)))
+ ("python-pathpy" ,python-pathpy)
+ ("python-pyhamcrest" ,python-pyhamcrest)
+ ("python-pytest" ,python-pytest)))
(propagated-inputs
`(("python-six" ,python-six)
("python-parse" ,python-parse)